dev-util/mdds: 1.6.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 12:12:09 +0000 (14:12 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 13:48:37 +0000 (15:48 +0200)
Remains at API 1.5 (SLOT 1/1.5)

Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/mdds/Manifest
dev-util/mdds/mdds-1.6.0.ebuild [new file with mode: 0644]
dev-util/mdds/mdds-9999.ebuild

index c2d2a2288a4aaada6f6ed407eeaa27ad1a563808..52cda54666ac4e8c7937d40d5a2191f30932e537 100644 (file)
@@ -1,2 +1,3 @@
 DIST mdds-1.4.3.tar.bz2 334515 BLAKE2B 3a42b7858346b2907040b8e42b1fae56626fc0881737ed04e20ffe4f9a23d2a2459c45e4244ac77745d2b1c7e3ff1642fe883b16def36e56c5c3d15077445793 SHA512 fd54a93fde89bff74a5ccf84ce5e2e002114297b165ded56a1bae92b28d70864775add140e165c7750f7dbe8ca1bfe83179cd9a835e53312c2e893c9e1f4434c
 DIST mdds-1.5.0.tar.bz2 346888 BLAKE2B c5c33649b6d8ba7d289eafe39c00c4334caa04f2a619d396e4f2499db9d66f48cb3ad0081805e7cef93bda49c24e6ce1a50c85a5e738120ee575c319959f6129 SHA512 9ed434dbc00285defbf3e0989396a1b52439bfdda01e5fd5822fef5e42e2c9b0b9436dd11b99af84a09a1965191ec106114e4046834f5b733474759f43bbfd95
+DIST mdds-1.6.0.tar.bz2 350406 BLAKE2B 70a99d779f318140f37bb3f873f1845c153f389a9e671a4d9ee4d1f0e762db312d536392061923c3c02494df6945a5a7743480eca1020d9cda6f3495888d7b00 SHA512 7c66894748e998f24374a5c6ea342ae2736e4bdba53be89510a1674690517ed7303786e1290fcfa26b07f236788c192ad29790129c228074397ab43699cdb290
diff --git a/dev-util/mdds/mdds-1.6.0.ebuild b/dev-util/mdds/mdds-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..dce2572
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+       EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+       inherit git-r3
+else
+       SRC_URI="https://kohei.us/files/${PN}/src/${P}.tar.bz2"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+
+LICENSE="MIT"
+SLOT="1/1.5"
+IUSE="doc valgrind test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       doc? (
+               app-doc/doxygen
+               dev-python/sphinx
+       )
+       valgrind? ( dev-util/valgrind )
+"
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.0-buildsystem.patch" )
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable doc docs)
+               $(use_enable valgrind memory_tests)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       tc-export CXX
+
+       default
+}
index 37717bcfe9a53df4321f1b57a037abd993d9e2ba..1bede682c2d94835330b99829495dfd35f7a67a5 100644 (file)
@@ -16,7 +16,7 @@ DESCRIPTION="A collection of multi-dimensional data structure and indexing algor
 HOMEPAGE="https://gitlab.com/mdds/mdds"
 
 LICENSE="MIT"
-SLOT="1/${PV%.*}"
+SLOT="1/${PV%.*}" # Check API version on version bumps!
 IUSE="doc valgrind test"
 RESTRICT="!test? ( test )"