dev-python/utidylib: 0.6 version bump, EAPI-7 bump, python3_8
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 15:41:49 +0000 (16:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 24 Nov 2019 17:13:32 +0000 (18:13 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/utidylib/Manifest
dev-python/utidylib/utidylib-0.6.ebuild [new file with mode: 0644]

index f19926dc22b181e5fd0dd51cd46cb7ae2f96682a..bbf80b3d44c7f5d73f48858a548dd60506924e1f 100644 (file)
@@ -1 +1,2 @@
 DIST uTidylib-0.3.tar.bz2 13809 BLAKE2B c6b495933ecdc21543c79e3ff200cc06ec4ebc1682cf9172bd988a08afef8b69db17eec4b88665aff5dc6cef371f3c665f6de3ffcc1dc515f778b523333c891b SHA512 4503f2a6366e5110740b312df2300d62bb68e1e1032184e9b56dee75995309c76d4f8e5851c73e7c8e08cca7bba9c74436d8dfc0524f115f3abb2bdf5529cc35
+DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
diff --git a/dev-python/utidylib/utidylib-0.6.ebuild b/dev-python/utidylib/utidylib-0.6.ebuild
new file mode 100644 (file)
index 0000000..b37e9e1
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+       doc? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+       test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
+"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7) )
+       test? (
+               $(python_gen_cond_dep 'dev-python/flake8[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+               $(python_gen_cond_dep 'dev-python/pycodestyle[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+               $(python_gen_cond_dep 'dev-python/pyflakes[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+               $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+               $(python_gen_cond_dep 'dev-python/pytest-cov[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
+       )
+"
+DEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       app-text/tidy-html5
+"
+
+RESTRICT="test" # 1/11 tests fail
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}