dev-python/doublex-expects: add version 0.7.0_rc1
authorAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 23:59:59 +0000 (18:59 -0500)
committerAlex Brandt <alunduil@gentoo.org>
Sat, 29 Aug 2015 23:59:59 +0000 (18:59 -0500)
Package-Manager: portage-2.2.20.1

dev-python/doublex-expects/Manifest
dev-python/doublex-expects/doublex-expects-0.7.0_rc1.ebuild [new file with mode: 0644]

index 06e4626443b2ee9a51aa519d3846d3106980f8c4..7cfeb5b818b724a6a69b644197c70fd260ee6484 100644 (file)
@@ -1 +1,2 @@
 DIST doublex-expects-0.4.0.tar.gz 4633 SHA256 59693e28bf9c15b9c2cb85bb2d7af53c48ea9ce4cd094746be375672eef45f1e SHA512 be8eabaf73684a2368d527838a18b3e8c516c4fe63aad3d87765e347b7a84450cb9b76d86ba26c2b684440ecb5d5ff77c82cc7f432ffa7f0ab28a2e01599dd10 WHIRLPOOL 5f2e271e7f50c4b6d74fb359f774074b80ea6fb830d3e2c706d046c199e2fbc2c0125ea72e755d245494a9e3d1b6109c420bf6398314cbce09cf85784e672297
+DIST doublex-expects-0.7.0_rc1.tar.gz 6087 SHA256 a83447e4a6ea1305c8971e3d8935f242c4f8813332b26db576064e75fbfe1088 SHA512 fa97080af78aa29c3efa70b89f3afeb4a5537393d3dbd3e94df01d590c046623fc70c25b147b761d1047cd0f154dcb46a3c07674b39fb591d0adcbccce491abd WHIRLPOOL b6732c0cdaffadca718da74e9ac8d1acc6d2742624c5e34306d0df01fe15e3ad2c315e13f0dceab2256fe8f2b13121d55894df19306b99970c9715bca1bc7745
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.0_rc1.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.0_rc1.ebuild
new file mode 100644 (file)
index 0000000..d0ec5e6
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="https://github.com/jaimegildesagredo/doublex-expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/mamba[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+       dev-python/doublex[${PYTHON_USEDEP}]
+       >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+
+python_test() {
+       mamba || die "Tests failed under ${EPYTHON}"
+}