sys-apps/flashrom: EAPI bump and point to new source repo
authorMarty E. Plummer <hanetzer@startmail.com>
Tue, 27 Mar 2018 03:19:46 +0000 (22:19 -0500)
committerAaron Bauman <bman@gentoo.org>
Tue, 27 Mar 2018 22:59:01 +0000 (18:59 -0400)
svn repo no longer works. also the pkg-config sed is no longer required
as of flashrom-0.9.9

Closes: https://bugs.gentoo.org/598028
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Closes: https://github.com/gentoo/gentoo/pull/7634

sys-apps/flashrom/flashrom-9999.ebuild

index 5e764d19fc7d41a3e9d7923cfb36814bd1787aac..c49046ce83b9057622be573d4dcc6e1df1de91b3 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI=6
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 if [[ ${PV} == "9999" ]] ; then
-       ESVN_REPO_URI="https://code.coreboot.org/svn/flashrom/trunk"
-       inherit subversion
+       EGIT_REPO_URI="https://review.coreboot.org/flashrom.git"
+       inherit git-r3
 else
        SRC_URI="https://download.flashrom.org/releases/${P}.tar.bz2"
        KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -64,12 +64,6 @@ flashrom_enable() {
        for u ; do _flashrom_enable "${u}" ; done
 }
 
-src_prepare() {
-       sed -i \
-               -e 's:pkg-config:$(PKG_CONFIG):' \
-               Makefile || die
-}
-
 src_compile() {
        # Help keep things in sync.
        local sprogs=$(echo $(