gnome 2.16
authorDaniel Gryniewicz <dang@gentoo.org>
Thu, 7 Sep 2006 02:52:21 +0000 (02:52 +0000)
committerDaniel Gryniewicz <dang@gentoo.org>
Thu, 7 Sep 2006 02:52:21 +0000 (02:52 +0000)
Package-Manager: portage-2.1.1_rc1-r2

x11-libs/pango/ChangeLog
x11-libs/pango/files/digest-pango-1.14.3 [new file with mode: 0644]
x11-libs/pango/pango-1.14.3.ebuild [new file with mode: 0644]

index faaea820adc7f25359cc54042ebed4cf6ad05b51..8cab809752e76cc92e0f9ec0b3096bb4d3821e93 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/pango
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.147 2006/08/16 18:15:07 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.148 2006/09/07 02:52:21 dang Exp $
+
+*pango-1.14.3 (07 Sep 2006)
+
+  07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org> -pango-1.13.2.ebuild,
+  +pango-1.14.3.ebuild:
+  New version for gnome 2.16
 
   16 Aug 2006; Markus Rothe <corsair@gentoo.org> pango-1.12.3.ebuild:
   Stable on ppc64
diff --git a/x11-libs/pango/files/digest-pango-1.14.3 b/x11-libs/pango/files/digest-pango-1.14.3
new file mode 100644 (file)
index 0000000..b2eb1e4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 afaf7128791f31b225079f73322eb67d pango-1.14.3.tar.bz2 1287606
+RMD160 82fdba3bfad68a478fd3a19f444f7af6dab2762a pango-1.14.3.tar.bz2 1287606
+SHA256 99d759e629074faea461c833efeaeda49c8cf9ba534bea23a8966e326757164a pango-1.14.3.tar.bz2 1287606
diff --git a/x11-libs/pango/pango-1.14.3.ebuild b/x11-libs/pango/pango-1.14.3.ebuild
new file mode 100644 (file)
index 0000000..4267d52
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.14.3.ebuild,v 1.1 2006/09/07 02:52:21 dang Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| (
+                               (
+                                       x11-libs/libXrender
+                                       x11-libs/libX11
+                                       x11-libs/libXft
+                               )
+                               virtual/x11
+                       )
+       >=dev-libs/glib-2.10.0
+       >=media-libs/fontconfig-1.0.1
+       >=media-libs/freetype-2
+       >=x11-libs/cairo-1.2.2"
+
+DEPEND="${RDEPEND}
+       >=dev-util/pkgconfig-0.9
+       || ( x11-proto/xproto virtual/x11 )
+       doc?    (
+                               >=dev-util/gtk-doc-1
+                               ~app-text/docbook-xml-dtd-4.1.2
+                       )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+       gnome2_src_unpack
+
+       # Some enhancements from Redhat
+       # These NEED to go upstream.
+       epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+       epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+       # make config file location host specific so that a 32bit and 64bit pango
+       # wont fight with each other on a multilib system
+       use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+       # and this line is just here to make building emul-linux-x86-gtklibs a bit
+       # easier, so even this should be amd64 specific.
+       use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+       epunt_cxx
+}
+
+src_install() {
+       gnome2_src_install
+
+       rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+       if [ "${ROOT}" == "/" ] ; then
+               einfo "Generating modules listing..."
+
+               use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+               use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+
+               PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+               mkdir -p ${PANGO_CONFDIR}
+
+               pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+       fi
+}