dev-python/os-win: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:45:03 +0000 (12:45 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:17 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/os-win/Manifest
dev-python/os-win/os-win-3.0.1.ebuild [deleted file]

index 860f4ff5eb397f9f5ede3f1518829144c0a5d87a..e56578aa68263fca96a90cd341dbb04572ab3044 100644 (file)
@@ -1,2 +1 @@
-DIST os-win-3.0.1.tar.gz 202691 BLAKE2B 934f90970ccdb7890379ca6f3545936db65f104414c4de51dd8956345b4e5330a3d6db286b6fc2cbc9f218528751fea56b7836d81cb9da1f271737817b220101 SHA512 619b893f4595fda57c2d339b10bf4a7de48c711829f1e2407f981c943b76999d1ee84c15a5b91b03fcd946f16754501cede2081c5ce0ae3ffea0e6f4faaaf23e
 DIST os-win-4.2.0.tar.gz 214676 BLAKE2B 689417494acd7ddf219b7b29d670ed888dc0649fddb5e0a94b5160b2bec66167c14a315e0daa2f0fa794de96cecb15a054cbc6f4df0c4c8d26abb2367eb06862 SHA512 5f828e5b0b0a178a65959bb69f88c7bf30282b71f458ac36c11ef197dac3e821a2cbfb8be43acbc90d845e247be990ce6618b6dbe60205af8e890c2f7b7d245e
diff --git a/dev-python/os-win/os-win-3.0.1.ebuild b/dev-python/os-win/os-win-3.0.1.ebuild
deleted file mode 100644 (file)
index 395a584..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
-HOMEPAGE="https://github.com/openstack/os-win"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
-       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
-       >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
-       !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
-       <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/win32/d' requirements.txt || die
-       distutils-r1_python_prepare_all
-}