net-im/telegram-desktop: drop old
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 20 Apr 2020 17:25:04 +0000 (10:25 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 20 Apr 2020 17:59:19 +0000 (10:59 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/telegram-desktop/Manifest
net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild [deleted file]
net-im/telegram-desktop/telegram-desktop-2.0.1.ebuild [deleted file]

index dddf94c4141e78c4a1fb3f4b1c96304e2667f5e6..a2241d57d0c4f5e5d523cc6e895b6db62ed39ce3 100644 (file)
@@ -1,3 +1,2 @@
-DIST tdesktop-1.9.14-full.tar.gz 25324084 BLAKE2B 45c071aa573541b6e483d2ae712b7f3b672c1294e8e7e624d9292f7176482f4d68069c35541019dc27fdb1c66134c29fb4d3667f1197e7085e4f8a80c8ca603c SHA512 56efa64048d23b280782b51319c0071c6cef833cb7e2584e52c6e45488577755beb85185ec9187029c425cc8d4c9c1887142687c744697e7731a15abe2846056
 DIST tdesktop-1.9.21-full.tar.gz 25848026 BLAKE2B 503e22bcc83a64721aa4c4c6e8bca89c4c976703c338b1615c5ab1599098e98cbd220a94cffdbe24d9c305b44ffef7719ad1c2d2ad81f4ec6edc8377e1afa4ef SHA512 ea02fc69e88ed6244ed420516bb7a93827cb85efaa0a7e9af7562aa1bc29184c5a2102caca8693c976b25d374832e0deb2ccbf00144d5340b5ffacbdc9dcebf1
 DIST tdesktop-2.0.1-full.tar.gz 26106949 BLAKE2B 3975e7d42af8b323a86408e2301b292d94b308413bb92d135673fb12851cd6672156dcf9b631482fa9b8dc9361d9593dc1104c8c335e0c610706b308414db01b SHA512 99cd7c5ca1e9dd75ecd98d272522b0e4aab2d46525e3d0c306503b7a00c9d25c1646e9d7462182682a58947c7435864af805a3b6f85906d8b21e5675cc8383cb
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.14.ebuild
deleted file mode 100644 (file)
index 6c917ef..0000000
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
-
-MY_P="tdesktop-${PV}-full"
-
-DESCRIPTION="Official desktop client for Telegram"
-HOMEPAGE="https://desktop.telegram.org"
-SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3-with-openssl-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="+alsa dbus libressl pulseaudio spell"
-
-RDEPEND="
-       !net-im/telegram-desktop-bin
-       app-arch/lz4:=
-       app-arch/xz-utils
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       >=dev-cpp/ms-gsl-2.1.0
-       dev-cpp/range-v3
-       dev-libs/libdbusmenu-qt[qt5(+)]
-       dev-libs/xxhash
-       dev-qt/qtcore:5
-       dev-qt/qtdbus:5
-       dev-qt/qtimageformats:5
-       dev-qt/qtnetwork:5
-       dev-qt/qtsvg:5
-       media-libs/fontconfig:=
-       >=media-libs/libtgvoip-2.4.4_p20200212[alsa?,pulseaudio?]
-       media-libs/openal[alsa?,pulseaudio?]
-       media-libs/opus:=
-       media-video/ffmpeg:=[opus]
-       sys-libs/zlib[minizip]
-       virtual/libiconv
-       x11-libs/libva:=[X,drm]
-       x11-libs/libX11
-       || (
-               dev-qt/qtgui:5[jpeg,png,X(-)]
-               dev-qt/qtgui:5[jpeg,png,xcb(-)]
-       )
-       || (
-               dev-qt/qtwidgets:5[png,X(-)]
-               dev-qt/qtwidgets:5[png,xcb(-)]
-       )
-       pulseaudio? ( media-sound/pulseaudio )
-       spell? ( app-text/enchant:= )
-"
-
-DEPEND="
-       ${PYTHON_DEPS}
-       ${RDEPEND}
-"
-
-BDEPEND="
-       >=dev-util/cmake-3.16
-       virtual/pkgconfig
-"
-
-REQUIRED_USE="|| ( alsa pulseaudio )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
-       local mycxxflags=(
-               -Wno-deprecated-declarations
-               -Wno-error=deprecated-declarations
-               -Wno-switch
-       )
-
-       append-cxxflags "${mycxxflags[@]}"
-
-       # TODO: unbundle header-only libs, ofc telegram uses git versions...
-       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
-       # EXPECTED VARIANT
-       local mycmakeargs=(
-               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
-               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
-               -DDESKTOP_APP_USE_PACKAGED=ON
-               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
-               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
-               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
-               -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION=ON
-               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
-               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)"
-               -DTDESKTOP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
-       )
-
-       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
-               einfo "Found custom API credentials"
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
-                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
-               )
-       else
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
-               # Building with snapcraft API credentials by default
-               # Custom API credentials can be obtained here:
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
-               # After getting credentials you can export variables:
-               #  export MY_TDESKTOP_API_ID="17349""
-               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
-               # and restart the build"
-               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
-               # portage will use custom variable every build automatically
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="611335"
-                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
-               )
-       fi
-
-       cmake_src_configure
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}
diff --git a/net-im/telegram-desktop/telegram-desktop-2.0.1.ebuild b/net-im/telegram-desktop/telegram-desktop-2.0.1.ebuild
deleted file mode 100644 (file)
index a27721e..0000000
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
-
-MY_P="tdesktop-${PV}-full"
-
-DESCRIPTION="Official desktop client for Telegram"
-HOMEPAGE="https://desktop.telegram.org"
-SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3-with-openssl-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell"
-
-RDEPEND="
-       !net-im/telegram-desktop-bin
-       app-arch/lz4:=
-       app-arch/xz-utils
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       >=dev-cpp/ms-gsl-2.1.0
-       dev-cpp/range-v3
-       dev-libs/xxhash
-       dev-qt/qtcore:5
-       dev-qt/qtimageformats:5
-       dev-qt/qtnetwork:5
-       dev-qt/qtsvg:5
-       media-libs/fontconfig:=
-       >=media-libs/libtgvoip-2.4.4_p20200301[alsa?,pulseaudio?]
-       media-libs/openal[alsa?,pulseaudio?]
-       media-libs/opus:=
-       media-video/ffmpeg:=[opus]
-       sys-libs/zlib[minizip]
-       virtual/libiconv
-       x11-libs/libva:=[X,drm]
-       x11-libs/libX11
-       || (
-               dev-qt/qtgui:5[jpeg,png,X(-)]
-               dev-qt/qtgui:5[jpeg,png,xcb(-)]
-       )
-       || (
-               dev-qt/qtwidgets:5[png,X(-)]
-               dev-qt/qtwidgets:5[png,xcb(-)]
-       )
-       dbus? (
-               dev-qt/qtdbus:5
-               dev-libs/libdbusmenu-qt[qt5(+)]
-       )
-       enchant? ( app-text/enchant:= )
-       hunspell? ( >=app-text/hunspell-1.7:= )
-       pulseaudio? ( media-sound/pulseaudio )
-"
-
-DEPEND="
-       ${PYTHON_DEPS}
-       ${RDEPEND}
-"
-
-BDEPEND="
-       >=dev-util/cmake-3.16
-       virtual/pkgconfig
-"
-
-PDEPEND="media-fonts/open-sans"
-
-REQUIRED_USE="|| ( alsa pulseaudio )
-       spell? (
-               ^^ ( enchant hunspell )
-       )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
-       local mycxxflags=(
-               -Wno-deprecated-declarations
-               -Wno-error=deprecated-declarations
-               -Wno-switch
-       )
-
-       append-cxxflags "${mycxxflags[@]}"
-
-       # TODO: unbundle header-only libs, ofc telegram uses git versions...
-       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
-       # EXPECTED VARIANT
-       local mycmakeargs=(
-               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
-               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
-               -DDESKTOP_APP_USE_PACKAGED=ON
-               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
-               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
-               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
-               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
-               -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
-               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell
-               -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
-       )
-
-       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
-               einfo "Found custom API credentials"
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
-                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
-               )
-       else
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
-               # Building with snapcraft API credentials by default
-               # Custom API credentials can be obtained here:
-               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
-               # After getting credentials you can export variables:
-               #  export MY_TDESKTOP_API_ID="17349""
-               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
-               # and restart the build"
-               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
-               # portage will use custom variable every build automatically
-               mycmakeargs+=(
-                       -DTDESKTOP_API_ID="611335"
-                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
-               )
-       fi
-
-       cmake_src_configure
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       xdg_icon_cache_update
-       xdg_mimeinfo_database_update
-}