net-misc/freelan: Fix build with boost 1.63, bug #603998
authorAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 13:49:37 +0000 (14:49 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 23 Jan 2017 13:49:37 +0000 (14:49 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-misc/freelan/files/boost163.patch [new file with mode: 0644]
net-misc/freelan/freelan-2.0.ebuild

diff --git a/net-misc/freelan/files/boost163.patch b/net-misc/freelan/files/boost163.patch
new file mode 100644 (file)
index 0000000..33636ef
--- /dev/null
@@ -0,0 +1,24 @@
+Index: freelan-2.0/libs/freelan/src/core.cpp
+===================================================================
+--- freelan-2.0.orig/libs/freelan/src/core.cpp
++++ freelan-2.0/libs/freelan/src/core.cpp
+@@ -1766,7 +1766,8 @@ namespace freelan
+                       {
+                               m_logger(fscp::log_level::information) << "IPv4 address: " << m_configuration.tap_adapter.ipv4_address_prefix_length;
+-                              tap_config.ipv4.network_address = { m_configuration.tap_adapter.ipv4_address_prefix_length.address(), m_configuration.tap_adapter.ipv4_address_prefix_length.prefix_length() };
++                              asiotap::base_ip_network_address<boost::asio::ip::address_v4> a(m_configuration.tap_adapter.ipv4_address_prefix_length.address(), m_configuration.tap_adapter.ipv4_address_prefix_length.prefix_length());
++                              tap_config.ipv4.network_address = a;
+                       }
+                       else
+                       {
+@@ -1778,7 +1779,8 @@ namespace freelan
+                       {
+                               m_logger(fscp::log_level::information) << "IPv6 address: " << m_configuration.tap_adapter.ipv6_address_prefix_length;
+-                              tap_config.ipv6.network_address = { m_configuration.tap_adapter.ipv6_address_prefix_length.address(), m_configuration.tap_adapter.ipv6_address_prefix_length.prefix_length() };
++                              asiotap::base_ip_network_address<boost::asio::ip::address_v6> a(m_configuration.tap_adapter.ipv6_address_prefix_length.address(), m_configuration.tap_adapter.ipv6_address_prefix_length.prefix_length());
++                              tap_config.ipv6.network_address = a;
+                       }
+                       else
+                       {
index e6284f27071a70c375d631f420703af87d268144..cc4f590784be404e55f684f8f194d16bed20b1ed 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -30,7 +30,8 @@ src_prepare() {
        epatch \
                "${FILESDIR}/boost158.patch" \
                "${FILESDIR}/mf.patch" \
-               "${FILESDIR}/prefix.patch"
+               "${FILESDIR}/prefix.patch" \
+               "${FILESDIR}/boost163.patch"
 
        sed -e "s/CXXFLAGS='-O3'/CXXFLAGS=''/" \
                -e "s/CXXFLAGS=\['-Werror'\]/CXXFLAGS=[]/" \