x11-plugins/wmpop3lb: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Wed, 29 Jan 2020 17:49:53 +0000 (18:49 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Wed, 29 Jan 2020 18:26:59 +0000 (19:26 +0100)
Closes: https://bugs.gentoo.org/706550
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild

diff --git a/x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch b/x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch
new file mode 100644 (file)
index 0000000..5beb415
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -45,6 +45,7 @@ Window               iconwin, win;
+ GC                    NormalGC;
+ XpmIcon               wmgen;
+ Pixmap                pixmask;
++Display               *display;
+   /*****************/
+  /* Mouse Regions */
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+  /* Global variable */
+ /*******************/
+-Display               *display;
++extern Display                *display;
+   /***********************/
+  /* Function Prototypes */
index 99e7ab4db582c630178b4be010a267da980b1d78..05a951236c011cce2e8295060af099a33cb85e6e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -20,7 +20,8 @@ DEPEND="${RDEPEND}"
 S=${WORKDIR}/${P/-}
 
 PATCHES=( "${FILESDIR}"/${P}-fix-RECV-and-try-STAT-if-LAST-wont-work.patch
-       "${FILESDIR}"/${P}-list.patch )
+       "${FILESDIR}"/${P}-list.patch
+       "${FILESDIR}"/${P}-gcc-10.patch )
 
 src_prepare() {
        #Honour Gentoo CFLAGS