sys-block/targetcli-fb: drop 2.1.48-r2
authorDiogo Pereira <sir.suriv@gmail.com>
Sun, 19 Apr 2020 22:53:52 +0000 (23:53 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 21 Apr 2020 12:44:48 +0000 (15:44 +0300)
Signed-off-by: Diogo Pereira <sir.suriv@gmail.com>
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-block/targetcli-fb/Manifest
sys-block/targetcli-fb/files/targetcli-fb-2.1.48-python3.patch [deleted file]
sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild [deleted file]

index 0920a4dc8a7a8b2e564b080da8eca3028f1cf94a..0be8eca49fb45400407454f5413793140c24fada 100644 (file)
@@ -1,2 +1 @@
-DIST targetcli-fb-2.1.48.tar.gz 33777 BLAKE2B f24661777509a1e125cccaa12ca03eff9564e08bc3b5b3b1798b69a07bd7587b0089bcccbfa6c0166db51ec9f55fa663833e412ecab1614be43bcddf0521b1af SHA512 97351b29d8428e797f0cf7a7bab588f20368121d29fd8ed2afe2bf63aaf10aa7761e355e033772f6cbaf7aec2a1540cffae7dccad872a7e5885f200fa07dd420
 DIST targetcli-fb-2.1.49.tar.gz 34147 BLAKE2B 49ed4a610282af30308373cdf806832a3441dcab9a52cddb3f59bacdecb79f7308f316cc65f526d6ea1f9bb875d05e049e6cd7d99eb243f25546395ba6aaa38c SHA512 05fb6f638f808bf09089bdd110592b3ed3be49fc70cc1a71680de7bff40dc88425e69e9a99fdfcab712646cf131f78071edae46f214fdfee4b7090f47933c93a
diff --git a/sys-block/targetcli-fb/files/targetcli-fb-2.1.48-python3.patch b/sys-block/targetcli-fb/files/targetcli-fb-2.1.48-python3.patch
deleted file mode 100644 (file)
index ec771c4..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From ed5ff9b9505e50b545e86dfbdd32077f0ddda0cb Mon Sep 17 00:00:00 2001
-From: Taylor Jakobson <tjakobs@us.ibm.com>
-Date: Thu, 1 Feb 2018 14:44:32 -0600
-Subject: [PATCH] Use signed char instead of char
-
-Python3 does not have the "character" type, use signed char instead.
----
- targetcli/ui_backstore.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/targetcli/ui_backstore.py b/targetcli/ui_backstore.py
-index 3a2db10..5af448f 100644
---- a/targetcli/ui_backstore.py
-+++ b/targetcli/ui_backstore.py
-@@ -536,7 +536,7 @@ def _ui_block_ro_check(self, dev):
-         except (OSError, IOError):
-             raise ExecutionError("Could not open %s" % dev)
-         # ioctl returns an int. Provision a buffer for it
--        buf = array.array('c', [chr(0)] * 4)
-+        buf = array.array('b', [0] * 4)
-         try:
-             fcntl.ioctl(f, BLKROGET, buf)
-         except (OSError, IOError):
diff --git a/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild b/sys-block/targetcli-fb/targetcli-fb-2.1.48-r2.ebuild
deleted file mode 100644 (file)
index 9f7e58e..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 versionator
-
-MY_PV=$(replace_version_separator 2 '.fb' ${PV})
-
-DESCRIPTION="Command shell for managing Linux LIO kernel target"
-HOMEPAGE="https://github.com/open-iscsi/targetcli-fb"
-SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/configshell-fb[${PYTHON_USEDEP}]
-       dev-python/pygobject:3[${PYTHON_USEDEP}]
-       >=dev-python/rtslib-fb-2.1.62[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-       !sys-block/targetcli"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-PATCHES=( "${FILESDIR}/${P}-python3.patch" )
-
-src_install() {
-       distutils-r1_src_install
-
-       keepdir /etc/target /etc/target/backup
-       doman targetcli.8
-}