app-i18n/translate-shell: bump version to 0.9.6.6
authorFerenc Erki <erkiferenc@gmail.com>
Thu, 8 Feb 2018 06:24:18 +0000 (07:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 11 Feb 2018 21:22:11 +0000 (22:22 +0100)
Closes: https://bugs.gentoo.org/617230
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-i18n/translate-shell/Manifest
app-i18n/translate-shell/translate-shell-0.9.6.6.ebuild [new file with mode: 0644]

index b1e19f97f9433a88b4268706008c5b2e49a2e43c..9e4183b46555a43ba013b71b523b3ecb7cced14d 100644 (file)
@@ -1 +1,2 @@
 DIST translate-shell-0.9.6.2.tar.gz 69544 BLAKE2B b49a2c6d7101f5063c8c548c2dcd26ed8b5a310d5e723293b8082bb1bdffbb926fb6f0050953825c9fc4567880cfbf1e9956236db3c28b176db851983c743d0d SHA512 a7bd3fba43485a22c2fdd4261c24579b03aeafefa40863c3b8eb1c814a167b9a6f5700086c1cd411063c66c169875b96d2634ed04f45beb6d53b4725eb7fbea9
+DIST translate-shell-0.9.6.6.tar.gz 73189 BLAKE2B ad4de403f2c95a1e4de5c963cb017f5a744f08d3bb8256dcc22f28c0916f6a0e693bce171a5dc500de5353c954bab7681f1227df9e48be286ad5aa07c5d06fa4 SHA512 c5451e537f44e325ee2f59d54942f91b8e2ccc0e322c42a2c4a0e98b8a933fe0630798a45e6f587ad5aee2cbb092204710ae36779c94b8333376a8072678d868
diff --git a/app-i18n/translate-shell/translate-shell-0.9.6.6.ebuild b/app-i18n/translate-shell/translate-shell-0.9.6.6.ebuild
new file mode 100644 (file)
index 0000000..30db5d9
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Online command-line translator"
+HOMEPAGE="https://www.soimort.org/translate-shell/"
+SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+curl +bidi test tts"
+
+RDEPEND="
+       app-misc/rlwrap
+       >=sys-apps/gawk-4.0.2
+       curl? ( net-misc/curl[ssl] )
+       bidi? ( dev-libs/fribidi )
+       tts? ( || (
+               media-sound/mpg123
+               app-accessibility/espeak
+               media-video/mpv
+               media-video/mplayer
+               )
+       )"
+DEPEND="${RDEPEND}
+       test? ( app-editors/emacs )
+       "
+
+src_install() {
+       emake PREFIX="${D}/usr" install
+}