dev-python/pygccxml: Drop unncessary die
authorJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:05:06 +0000 (09:05 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:53:17 +0000 (09:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pygccxml/pygccxml-1.0.0.ebuild

index 2e4cae479cf13a8e037f4e009b707f9993e5c4d7..0836d5058f5b695f72545ceaa60ea45f06ac4320 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
@@ -16,14 +17,13 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="doc examples"
 
-DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
-       app-arch/unzip"
+DEPEND="
+       app-arch/unzip
+       doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )"
 RDEPEND=">=dev-cpp/gccxml-0.6"
 
 python_compile_all() {
-       if use doc; then
-               esetup.py doc || die
-       fi
+       use doc && esetup.py doc
 }
 
 python_test() {