dev-python/pytest-localserver: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Sat, 14 Mar 2020 16:28:53 +0000 (17:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 14 Mar 2020 16:32:55 +0000 (17:32 +0100)
Closes: https://bugs.gentoo.org/712522
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild

index 703c4b619ced2374ddc78af9060fc1db844e445b..ded39fc15de0b6d123a987064001233e37d6d56a 100644 (file)
@@ -2,7 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=(python{2_7,3_{6,7,8}} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
 
 inherit distutils-r1
 
@@ -13,10 +15,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
-IUSE="test"
 
 RDEPEND=">=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]