sys-process/glances: rebvump 3.1.3, fix tests, disable update check
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 28 Dec 2019 08:58:44 +0000 (00:58 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 28 Dec 2019 08:59:02 +0000 (00:59 -0800)
Disable nagging suggestion to upgrade using pip, patch imported from debian

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-process/glances/files/disable-update-check.patch [new file with mode: 0644]
sys-process/glances/glances-3.1.3-r1.ebuild [moved from sys-process/glances/glances-3.1.3.ebuild with 95% similarity]

diff --git a/sys-process/glances/files/disable-update-check.patch b/sys-process/glances/files/disable-update-check.patch
new file mode 100644 (file)
index 0000000..3706959
--- /dev/null
@@ -0,0 +1,28 @@
+Description: Disable nagging suggestion to upgrade using pip
+Author: Sebastien Badia <sbadia@debian.org>
+Bug-Debian: https://bugs.debian.org/877127
+Forwarded: not-needed
+Last-Update: 2019-02-07
+
+--- a/glances/standalone.py
++++ b/glances/standalone.py
+@@ -92,9 +92,6 @@
+             # Init screen
+             self.screen = GlancesCursesStandalone(config=config, args=args)
+-        # Check the latest Glances version
+-        self.outdated = Outdated(config=config, args=args)
+-
+     @property
+     def quiet(self):
+         return self._quiet
+@@ -156,9 +153,3 @@
+         # Exit from export modules
+         self.stats.end()
+-
+-        # Check Glances version versus PyPI one
+-        if self.outdated.is_outdated():
+-            print("You are using Glances version {}, however version {} is available.".format(
+-                self.outdated.installed_version(), self.outdated.latest_version()))
+-            print("You should consider upgrading using: pip install --upgrade glances")
similarity index 95%
rename from sys-process/glances/glances-3.1.3.ebuild
rename to sys-process/glances/glances-3.1.3-r1.ebuild
index 123e7d05a159c68e313aea3cc247510a0537caeb..f618736435a839dc7330662e6fcf77285cc27b92 100644 (file)
@@ -22,9 +22,12 @@ RDEPEND="dev-python/future[${PYTHON_USEDEP}]
 
 CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS"
 
-PATCHES=( "${FILESDIR}/${PV}-fix-test.patch" )
+PATCHES=(
+       "${FILESDIR}/disable-update-check.patch"
+       "${FILESDIR}/${PV}-fix-test.patch"
+)
 
-distutils_enable_tests unittest
+distutils_enable_tests setup.py
 distutils_enable_sphinx docs --no-autodoc
 
 pkg_setup() {