dev-python/autobahn: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:40:47 +0000 (12:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 11:47:57 +0000 (12:47 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/autobahn/Manifest
dev-python/autobahn/autobahn-17.10.1.ebuild [deleted file]
dev-python/autobahn/autobahn-17.9.1.ebuild [deleted file]
dev-python/autobahn/autobahn-17.9.2.ebuild [deleted file]

index 7e99c02154cd08ef4178f5635ca643ca1bf6b94f..91e225aae21804a8e08df032fb8f915fc6010b7a 100644 (file)
@@ -1,5 +1,2 @@
-DIST autobahn-17.10.1.tar.gz 212093 BLAKE2B 1505097dee07025c5433645397bb52807dbd67559b628ee80735a49f8e085e9c8433fbd453a4d001996dd5aee715c9278b9932e8fbb65ecd6458b6b4bd4a804d SHA512 f26c1c88bea325136f640420ada0fc70e82397ed660056c18f68a2193f069c5fb5771ac620db1583f8c7938e804726d8885d237c925c4bd38d1a613a6aabc219
 DIST autobahn-17.5.1.tar.gz 205144 BLAKE2B a026381330d062059f23bd0fe20de12bf227fec45c816ce41a05d81951a2cb263e70ec3a5cee265ea3cc1f6910975903b493a767dce64c5bbb13be077561cabd SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382
-DIST autobahn-17.9.1.tar.gz 209230 BLAKE2B 4e637ee22fe84c51b294faa853034b65e5bc7b230d1d80eea022a2e3809a7ff0c9ffee7c13886f154efffdcdedf5c790e5891466107670c3221a5c7b5de846ea SHA512 036508c1170f53b01be360083bbf9f569fbaf216d984b34e10ad18e5f5e156e74bd4c8979bdd977a8e23deff0332e16d3d606716d32f3987ff37c7707eac0f86
-DIST autobahn-17.9.2.tar.gz 209442 BLAKE2B 66d31a575d980d81ecd50d9511ed49b947a568ce5457db2de7fd67a85ae06016bacff10f65b74f43c2b72b21543ddb8c0d527f6b9ece706c67adb96860435232 SHA512 de73a4cc99616802d280887ef8a9971c532f974dd43cda933da953d7bcc45da3fd9d0c91763c6a80371f582f0acc9741134b1ba1b98035ef0f63e4971aaff79f
 DIST autobahn-18.3.1.tar.gz 213042 BLAKE2B 2f5eb92212f57d2301dbac1108a81cbbd339da4cb5527e3eb55f1ae7dcb951fed3cb7c643e76beaa0a83d623fe96f9eebcf7945e10efb0773e102d0234ebc479 SHA512 3d122cfb54eff0697cf60cd155a07699c6f6b39e573616c247ea79e65e6fa0a86d505ea8bc4f4755dbf266fb8bc7fadabb4338aeb1b9e6a2f0503e1b4d25e2e6
diff --git a/dev-python/autobahn/autobahn-17.10.1.ebuild b/dev-python/autobahn/autobahn-17.10.1.ebuild
deleted file mode 100644 (file)
index aeeff69..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-
-DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
-HOMEPAGE="https://pypi.org/project/autobahn/
-       https://crossbar.io/autobahn/
-       https://github.com/crossbario/autobahn-python"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="crypt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
-       >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
-       >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
-       >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
-       >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
-       >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
-       crypt? (
-               >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-               >=dev-python/service_identity-16.0.0
-       )
-       "
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_test() {
-       #esetup.py test
-       cd "${BUILD_DIR}"/lib || die
-       py.test -v || die
-}
-
-pkg_postinst() {
-       python_foreach_impl twisted-regen-cache || die
-}
-
-pkg_postrm() {
-       python_foreach_impl twisted-regen-cache || die
-}
diff --git a/dev-python/autobahn/autobahn-17.9.1.ebuild b/dev-python/autobahn/autobahn-17.9.1.ebuild
deleted file mode 100644 (file)
index aeeff69..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-
-DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
-HOMEPAGE="https://pypi.org/project/autobahn/
-       https://crossbar.io/autobahn/
-       https://github.com/crossbario/autobahn-python"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="crypt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
-       >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
-       >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
-       >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
-       >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
-       >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
-       crypt? (
-               >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-               >=dev-python/service_identity-16.0.0
-       )
-       "
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_test() {
-       #esetup.py test
-       cd "${BUILD_DIR}"/lib || die
-       py.test -v || die
-}
-
-pkg_postinst() {
-       python_foreach_impl twisted-regen-cache || die
-}
-
-pkg_postrm() {
-       python_foreach_impl twisted-regen-cache || die
-}
diff --git a/dev-python/autobahn/autobahn-17.9.2.ebuild b/dev-python/autobahn/autobahn-17.9.2.ebuild
deleted file mode 100644 (file)
index aeeff69..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 versionator
-
-MY_P="${PN}-$(replace_version_separator 3 -)"
-
-DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
-HOMEPAGE="https://pypi.org/project/autobahn/
-       https://crossbar.io/autobahn/
-       https://github.com/crossbario/autobahn-python"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="crypt test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
-       >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
-       >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
-       >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
-       >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
-       >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
-       >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
-       >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
-       crypt? (
-               >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-               >=dev-python/service_identity-16.0.0
-       )
-       "
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
-               >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
-               >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}"/${MY_P}
-
-python_test() {
-       #esetup.py test
-       cd "${BUILD_DIR}"/lib || die
-       py.test -v || die
-}
-
-pkg_postinst() {
-       python_foreach_impl twisted-regen-cache || die
-}
-
-pkg_postrm() {
-       python_foreach_impl twisted-regen-cache || die
-}