dev-python/pymongo: 3.7.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 04:28:06 +0000 (23:28 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:04:48 +0000 (02:04 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pymongo/Manifest
dev-python/pymongo/pymongo-3.7.2.ebuild [new file with mode: 0644]

index 25d103921eeca125d74ef8ee9ba71e4214e03697..deaf685626d531cdb47e55eba34c08cec3d701e4 100644 (file)
@@ -1,3 +1,4 @@
 DIST pymongo-3.4.0.tar.gz 583303 BLAKE2B 2031b52731db8c5def167b2aceb4e1d064f0ff2391f71d2507cfc03ab932b4e1150d61a7b039b6183f5aa305e5e562110709a858174f37f0523d44d50d7c642c SHA512 c59dcc08803f23134aa4a86605fab0f5c59b829325b632fc1e0149f20018a544b3d65f3c1fda6066248cd258715339b1771ca8d40c38be02c301f5b6421abd1b
 DIST pymongo-3.5.1.tar.gz 1332463 BLAKE2B d581409a4b6cdede3e126e31747d34ed0e238919163ed442477ae51765ebdd1ebfb53fc94f7f1f53161c2019bf9db46640730aa54f19af6af25a37c95372308d SHA512 67526bcc27233b85226d7ef6aacce6dfb848efc88730fb8207c3b610f3943ac813f6c2842b7e514d733a65a2b7ea4f255574732e42372551b1b333e3437fd82f
 DIST pymongo-3.7.1.tar.gz 723014 BLAKE2B fd0be64f01006405f30e8d96e5edc0d565a8b67ec057a27b6143b4dd0592e2302efea65b6e3d4898d12e196b1efe01787aa608d8564573a83bfd193c703ba0c4 SHA512 34f7448c90a0741d1c80e5924d53e70d5c4bf74d140ea50cef1a519e11b7429dc8551ddb868ec4c02351da6619924ae0d4f7bfc12ef4fa9635c81e2f69aea30f
+DIST pymongo-3.7.2.tar.gz 628611 BLAKE2B 4eac5f11c8cd9a1bf8e0553a1fc3ec8f0a4bec0fd6b04dd75fe85da7315baa0e81a3c2b2aa4eba351aa4206aae974bce263f0630ac8828d8a982c4902cf7f518 SHA512 4d1dfe03d94f381f27cfb5c8dd4f75ecbab90567fdc4dd594b880031e68825eda6285c8b261a4c9d76fb7ccc92c91e27ae2f696525f7732b1f0084794042a33d
diff --git a/dev-python/pymongo/pymongo-3.7.2.ebuild b/dev-python/pymongo/pymongo-3.7.2.ebuild
new file mode 100644 (file)
index 0000000..a2819e6
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit check-reqs distutils-r1
+
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="doc kerberos test"
+
+RDEPEND="
+       kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+DEPEND="
+       ${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               >=dev-db/mongodb-2.6.0
+       )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+reqcheck() {
+       if use test; then
+               # During the tests, database size reaches 1.5G.
+               local CHECKREQS_DISK_BUILD=1536M
+
+               check-reqs_${1}
+       fi
+}
+
+pkg_pretend() {
+       reqcheck pkg_pretend
+}
+
+pkg_setup() {
+       reqcheck pkg_setup
+}
+
+python_compile_all() {
+       if use doc; then
+               mkdir html || die
+               sphinx-build doc html || die
+       fi
+}
+
+python_test() {
+       # Yes, we need TCP/IP for that...
+       local DB_IP=127.0.0.1
+       local DB_PORT=27000
+
+       export DB_IP DB_PORT
+
+       local dbpath=${TMPDIR}/mongo.db
+       local logpath=${TMPDIR}/mongod.log
+
+       # Now, the hard part: we need to find a free port for mongod.
+       # We're just trying to run it random port numbers and check the log
+       # for bind errors. It shall be noted that 'mongod --fork' does not
+       # return failure when it fails to bind.
+
+       mkdir -p "${dbpath}" || die
+       while true; do
+               ebegin "Trying to start mongod on port ${DB_PORT}"
+
+               LC_ALL=C \
+               mongod --dbpath "${dbpath}" --smallfiles --nojournal \
+                       --bind_ip ${DB_IP} --port ${DB_PORT} \
+                       --unixSocketPrefix "${TMPDIR}" \
+                       --logpath "${logpath}" --fork \
+               && sleep 2
+
+               # Now we need to check if the server actually started...
+               if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+                       # yay!
+                       eend 0
+                       break
+               elif grep -q 'Address already in use' "${logpath}"; then
+                       # ay, someone took our port!
+                       eend 1
+                       : $(( DB_PORT += 1 ))
+                       continue
+               else
+                       eend 1
+                       eerror "Unable to start mongod for tests. See the server log:"
+                       eerror "        ${logpath}"
+                       die "Unable to start mongod for tests."
+               fi
+       done
+
+       local failed
+       #https://jira.mongodb.org/browse/PYTHON-521, py2.[6-7] has intermittent failure with gevent
+       pushd "${BUILD_DIR}"/../ > /dev/null
+       if [[ "${EPYTHON}" == python3* ]]; then
+               2to3 --no-diffs -w test
+       fi
+       DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+       mongod --dbpath "${dbpath}" --shutdown || die
+
+       [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+       rm -rf "${dbpath}" || die
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( html/. )
+
+       distutils-r1_python_install_all
+}