dev-perl/B-Utils: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Tue, 5 May 2020 14:56:25 +0000 (02:56 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 5 May 2020 15:05:50 +0000 (03:05 +1200)
- EAPI7
- Strip useless tests that merely clutter test output

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/B-Utils/B-Utils-0.270.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/B-Utils/B-Utils-0.270.0-r1.ebuild b/dev-perl/B-Utils/B-Utils-0.270.0-r1.ebuild
new file mode 100644 (file)
index 0000000..1c81544
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# needs Scalar::Util
+RDEPEND="
+       virtual/perl-Exporter
+       virtual/perl-Scalar-List-Utils
+       dev-perl/Task-Weaken
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-CBuilder
+       >=dev-perl/ExtUtils-Depends-0.301.0
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PERL_RM_FILES=(
+       # These useless no-op tests that simply clutter test output
+       t/utils/{31oldname,32kids,33ancestors,34descendants,35siblings,36previous,37stringify}.t
+       t/utils/{41walkfilt,42all,43allfilt,44optrep}.t
+       t/utils/{50carp,51croak}.t
+)