games-simulation/openrct2: bump to version 0.2.5
authorConrad Kostecki <conikost@gentoo.org>
Tue, 7 Apr 2020 16:08:17 +0000 (18:08 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Tue, 7 Apr 2020 16:08:37 +0000 (18:08 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
games-simulation/openrct2/Manifest
games-simulation/openrct2/openrct2-0.2.5.ebuild [new file with mode: 0644]

index e6fbee6b94ee388335d2bfd8f06f8858c8d8aa58..98c1c90754ff7cd7a4875503caf9508f51d4ec1a 100644 (file)
@@ -1,4 +1,5 @@
 DIST openrct2-0.2.4.tar.gz 6805976 BLAKE2B 7860746d1705804682756097ff37d4584d0ebb20c450c08b88134795e9f3c375dfb888a67302f530cd55700eaa5cd13149c365c30a5d267d382b39225f06d210 SHA512 956044b5fa5e55256a33f352d2d1e8a4eb6738b98dc9894807b3628b5c5c08f3229c952fbf8b33ad867771f88c6d7e17ad1a8a4e050f8f269a6152d013afce03
+DIST openrct2-0.2.5.tar.gz 11076466 BLAKE2B 7e3aff0e2a322b1a0319df6ebdc335052d5aeb0c35dc97123fcf316272e95171ced5f9f41695d986b69b93cdacfa755fef924e2ff87a3f2441e03fd33175a2cc SHA512 8ab091788a52408ef37d603581841a12ffbe5a5eced43504d8e19e89d26b1320010dc0b4a4b67080260e66e24edeb2c780d7bad9b88b58e6a7216f4e393fc516
 DIST openrct2-objects-1.0.12.zip 2173875 BLAKE2B d344dde3dc376004b9e303a489c058a574c2f8babcce8c9998ef12f2b91e3fe7d3e22e1afc81aadd39637f3f91a5d36c4267aed06980686fd909cc515f4c8fde SHA512 d17d2197b66d22e33a246651a0c544a49a6d6a809612d26a851dc4b40bb9e1bf5079bbe5b1a3b7d41f541fc41ce41717d772a5579aa2cdc9ec1dfea72b5a3144
 DIST openrct2-objects-1.0.13.zip 2214431 BLAKE2B 6301c787364cb16a4f599c2b94d475237abd098715a98a0bfe87fc067d490f8939c5f25235350d9fed02c37d4f92a29c2bb021a9acf1615f161e5b5d95b8fd63 SHA512 690255506e3286bff00076f3dcb3ce50e98606dfc1e522aa679d5e6c7e01c5f56a6624a65bb8aab5915d7d71ae21de310642c16cd5154db6b096bedd77d5797e
 DIST openrct2-replays-0.0.4.zip 1098833 BLAKE2B efe4f72b16285d8e6508313f16b892b02f1b124cf9b4d146731280f5090d071d3351834e6d4ab51122804fbbcb49044be4e681182141aac93795c3b1953b6590 SHA512 5c2469bfdaa94a6007f6788878f4e80d87fbbfd48b522e1bd2a22c2aa0c98583159b9559fd45f7f9450d544a99a59b6c17399d9ac91a171a86135f0e1a5b3e71
diff --git a/games-simulation/openrct2/openrct2-0.2.5.ebuild b/games-simulation/openrct2/openrct2-0.2.5.ebuild
new file mode 100644 (file)
index 0000000..55734f4
--- /dev/null
@@ -0,0 +1,162 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils readme.gentoo-r1 xdg-utils
+
+MY_PN="OpenRCT2"
+MY_PN_OBJ="objects"
+MY_PN_RPL="replays"
+MY_PN_TS="title-sequences"
+MY_PV_OBJ="1.0.13"
+MY_PV_RPL="0.0.8"
+MY_PV_TS="0.1.2c"
+
+DESCRIPTION="An open source re-implementation of Chris Sawyer's RollerCoaster Tycoon 2"
+HOMEPAGE="https://openrct2.org/"
+SRC_URI="
+       https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       https://github.com/${MY_PN}/${MY_PN_OBJ}/releases/download/v${MY_PV_OBJ}/${MY_PN_OBJ}.zip -> ${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}.zip
+       https://github.com/${MY_PN}/${MY_PN_TS}/releases/download/v${MY_PV_TS}/${MY_PN_TS}.zip -> ${PN}-${MY_PN_TS}-${MY_PV_TS}.zip
+       test? ( https://github.com/${MY_PN}/${MY_PN_RPL}/releases/download/v${MY_PV_RPL}/${MY_PN_RPL}.zip -> ${PN}-${MY_PN_RPL}-${MY_PV_RPL}.zip )
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated libressl +lightfx +opengl test +truetype twitch"
+
+COMMON_DEPEND="
+       dev-libs/icu:=
+       dev-libs/jansson
+       dev-libs/libzip:=
+       media-libs/libpng:0=
+       sys-libs/zlib
+       !dedicated? (
+               media-libs/libsdl2
+               media-libs/speexdsp
+               opengl? ( virtual/opengl )
+               twitch? (
+                       net-misc/curl[ssl]
+               )
+       )
+       libressl? ( dev-libs/libressl:0= )
+       !libressl? ( dev-libs/openssl:0= )
+       truetype? (
+               media-libs/fontconfig:1.0
+               media-libs/freetype:2
+       )
+"
+
+RDEPEND="
+       ${COMMON_DEPEND}
+       dedicated? (
+               acct-group/openrct2
+               acct-user/openrct2
+       )
+"
+
+DEPEND="
+       ${COMMON_DEPEND}
+       test? ( dev-cpp/gtest )
+"
+
+BDEPEND="
+       app-arch/unzip
+       virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-0.2.4-include-additional-paths.patch"
+)
+
+src_unpack() {
+       unpack "${P}".tar.gz
+
+       mkdir -p "${S}"/data/title || die
+       cd "${S}"/data/title || die
+       unpack "${PN}-${MY_PN_TS}-${MY_PV_TS}".zip
+
+       mkdir -p "${S}"/data/object || die
+       cd "${S}"/data/object || die
+       unpack "${PN}-${MY_PN_OBJ}-${MY_PV_OBJ}".zip
+
+       if use test; then
+               mkdir -p "${S}"/testdata/replays || die
+               cd "${S}"/testdata/replays || die
+               unpack "${PN}-${MY_PN_RPL}-${MY_PV_RPL}".zip
+       fi
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       # Don't treat warnings as errors.
+       sed -e 's/-Werror//' -i CMakeLists.txt || die
+}
+
+src_configure() {
+       # Note: There is currently no support for Disord-RPC and Google Benchmark,
+       # as both packages do not exist in Gentoo, so support for them has been disabled.
+       local mycmakeargs=(
+               -DDISABLE_DISCORD_RPC=ON
+               -DDISABLE_GOOGLE_BENCHMARK=ON
+               -DDISABLE_GUI=$(usex dedicated)
+               -DDISABLE_HTTP_TWITCH=$(usex !twitch)
+               -DDISABLE_NETWORK=OFF
+               $(usex !dedicated "-DDISABLE_OPENGL=$(usex !opengl)" "")
+               -DDISABLE_TTF=$(usex !truetype)
+               -DDOWNLOAD_OBJECTS=OFF
+               -DDOWNLOAD_REPLAYS=OFF
+               -DDOWNLOAD_TITLE_SEQUENCES=OFF
+               -DENABLE_LIGHTFX=$(usex lightfx)
+               -DPORTABLE=OFF
+               -DSTATIC=OFF
+               $(usex test "-DSYSTEM_GTEST=ON" "")
+               -DWITH_TESTS=$(usex test)
+               -DUSE_MMAP=ON
+       )
+
+       cmake-utils_src_configure
+}
+
+src_test() {
+       # Since the tests need the OpenRCT2 data,
+       # we need to symlink them into the build directory,
+       # otherwise some tests will fail, as they don't find the OpenRCT2 data.
+       # It is currently not possible to override that path.
+       # See: https://github.com/OpenRCT2/OpenRCT2/issues/6473
+       ln -s "${S}"/data "${BUILD_DIR}" || die
+
+       cmake-utils_src_test
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use dedicated; then
+               newinitd "${FILESDIR}"/openrct2.initd openrct2
+               newconfd "${FILESDIR}"/openrct2.confd openrct2
+       fi
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}