sys-cluster/charliecloud: adhere to common styles
authorJoonas Niilola <juippis@gentoo.org>
Fri, 17 Apr 2020 14:52:29 +0000 (17:52 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 17 Apr 2020 15:10:31 +0000 (18:10 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-cluster/charliecloud/charliecloud-0.15.ebuild
sys-cluster/charliecloud/charliecloud-9999.ebuild

index 0085a7e407f1fb7dcfc5792381f250d5d0260b1a..54113d039cd47285b45dd6fa859e8f0f0bf5264a 100644 (file)
@@ -62,7 +62,7 @@ src_configure() {
                # Libdir is used as a libexec-style destination.
                --libdir="${EPREFIX}"/usr/lib
                # Attempts to call python-exec directly otherwise.
-               --with-sphinx-python=$(which python) \
+               --with-sphinx-python=${PYTHON}
        )
        econf "${econf_args[@]}"
 }
@@ -72,6 +72,6 @@ pkg_postinst() {
        elog "to the internal ch-grow. The following packages "
        elog "can be installed to get the corresponding support."
 
-       optfeature "Building with Buildah"      "app-emulation/buildah"
-       optfeature "Building with Docker"       "app-emulation/docker"
+       optfeature "Building with Buildah" app-emulation/buildah
+       optfeature "Building with Docker" app-emulation/docker
 }
index 0085a7e407f1fb7dcfc5792381f250d5d0260b1a..54113d039cd47285b45dd6fa859e8f0f0bf5264a 100644 (file)
@@ -62,7 +62,7 @@ src_configure() {
                # Libdir is used as a libexec-style destination.
                --libdir="${EPREFIX}"/usr/lib
                # Attempts to call python-exec directly otherwise.
-               --with-sphinx-python=$(which python) \
+               --with-sphinx-python=${PYTHON}
        )
        econf "${econf_args[@]}"
 }
@@ -72,6 +72,6 @@ pkg_postinst() {
        elog "to the internal ch-grow. The following packages "
        elog "can be installed to get the corresponding support."
 
-       optfeature "Building with Buildah"      "app-emulation/buildah"
-       optfeature "Building with Docker"       "app-emulation/docker"
+       optfeature "Building with Buildah" app-emulation/buildah
+       optfeature "Building with Docker" app-emulation/docker
 }