Bug #198398 - Make repoman bail out if support for RMD160 hash
authorZac Medico <zmedico@gentoo.org>
Wed, 12 Dec 2007 08:06:01 +0000 (08:06 -0000)
committerZac Medico <zmedico@gentoo.org>
Wed, 12 Dec 2007 08:06:01 +0000 (08:06 -0000)
creation appears to be missing.

svn path=/main/trunk/; revision=8887

bin/repoman

index f6ab04dc9a19772b9080be5371ec86afa4e233ab..783b4fb794ca5a04c70f0571d1a0100752c80882 100755 (executable)
@@ -809,6 +809,20 @@ if isCvs:
        mynew = cvstree.findnew(mycvstree, recursive=1, basedir="./")
        new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
        del mycvstree, mynew
+       if "commit" == options.mode and \
+               "RMD160" not in portage.checksum.hashorigin_map:
+               from portage.util import grablines
+               repo_lines = grablines("./CVS/Repository")
+               if repo_lines and repo_lines[0].startswith("gentoo-x86/"):
+                       msg = "Please install " \
+                       "pycrypto or enable python's ssl USE flag in order " \
+                       "to enable RMD160 hash support. See bug #198398 for " \
+                       "more information."
+                       prefix = red(" * ")
+                       from textwrap import wrap
+                       for line in wrap(msg, 70):
+                               print prefix + line
+                       sys.exit(1)
 
 dofail = 0
 arch_caches={}