dev-ros/rosbag: Bump to 1.13.0.
authorAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 08:59:13 +0000 (09:59 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 25 Feb 2017 09:54:49 +0000 (10:54 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ros/rosbag/Manifest
dev-ros/rosbag/rosbag-1.13.0.ebuild [new file with mode: 0644]

index caf895619d09ab232bf8d375a80dd1ff4133c09f..4257f76db5cebfca022e8957f2d0058dd8dcc2d9 100644 (file)
@@ -1 +1,2 @@
 DIST ros_comm-1.12.7.tar.gz 974568 SHA256 4c141270c9263ba1ceb0d510f9d17bfe229530a277bfe10762e88d25f46efd38 SHA512 7cfc5bf231e8e388102f192d46bd902a2b92d4620938379b362efd250c48f317f5ba6e0aee7398c841392f56c2b79f933ad5ec60eb69492add90fa2ca86a3a8f WHIRLPOOL 7537aa5b781b3426cbaa82bdb07b117045efc3f748af7413e6b52ee63f3b401e403966afb1ea305674a5613f6a191f0afa098ad16e63267ad2ec8e3117996eb0
+DIST ros_comm-1.13.0.tar.gz 974811 SHA256 01eee591e0462e267da5c01537faf609c11497b578d4426818919514a8589ea6 SHA512 8cd0f8cb40d51293946a87da0614921150aa87d168e0d38981f0b7eef3c0f514f14ff613efd192c9c898b3a90fedd0cba21a9f337a197377fd946f427369c60b WHIRLPOOL 6054aca71a7afb0a202b2b8e7baf9b06c51e41f86da0959909bfe130a63a88c684a385b7ef6f9ed8ce2c7c766d6ef78ef83fd8bd97b0cc519717087050122307
diff --git a/dev-ros/rosbag/rosbag-1.13.0.ebuild b/dev-ros/rosbag/rosbag-1.13.0.ebuild
new file mode 100644 (file)
index 0000000..c5e59ab
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+       dev-ros/rosbag_storage
+       dev-ros/rosconsole
+       dev-ros/roscpp
+       dev-ros/topic_tools
+       dev-ros/xmlrpcpp
+       dev-libs/boost:=
+       app-arch/bzip2
+       dev-ros/roslib[${PYTHON_USEDEP}]
+       dev-ros/genpy[${PYTHON_USEDEP}]
+       dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+       lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"