media-sound/musescore: Fix cmake (missing all.h)
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Aug 2018 21:34:45 +0000 (23:34 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 21 Aug 2018 21:34:45 +0000 (23:34 +0200)
Closes: https://bugs.gentoo.org/626618
Package-Manager: Portage-2.3.48, Repoman-2.3.10

media-sound/musescore/files/musescore-2.1.0-pch.patch [new file with mode: 0644]
media-sound/musescore/musescore-2.1.0-r1.ebuild

diff --git a/media-sound/musescore/files/musescore-2.1.0-pch.patch b/media-sound/musescore/files/musescore-2.1.0-pch.patch
new file mode 100644 (file)
index 0000000..d69d1cd
--- /dev/null
@@ -0,0 +1,31 @@
+From 5e8024c683891be677075d74cedfbf424e36bc31 Mon Sep 17 00:00:00 2001
+From: mirabilos <tg@debian.org>
+Date: Sun, 4 Mar 2018 16:38:21 +0100
+Subject: [PATCH] Fix numerous reports of missing all.h during compilation
+
+When disabling PCH, the all.h copying code is no longer run before
+AUTOMOC=caused *_autogen targets, so we must run it earlier.
+
+From Debian
+---
+ CMakeLists.txt | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 66b0ddfce8..7fdfffcc9b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -553,11 +553,8 @@ endif (NOT MINGW AND NOT APPLE)
+ #
+ # all.h is expected in PROJECT_BINARY_DIR by subdirs
+-add_custom_command(
+-    OUTPUT ${PROJECT_BINARY_DIR}/all.h
+-    COMMAND ${CMAKE_COMMAND}
+-    ARGS -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+-    DEPENDS ${PROJECT_SOURCE_DIR}/all.h
++execute_process(
++    COMMAND ${CMAKE_COMMAND} -E copy ${PROJECT_SOURCE_DIR}/all.h ${PROJECT_BINARY_DIR}/all.h
+     WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+     )
\ No newline at end of file
index 6abacb371c48cf4448b796dbe352b852ee5a2c8b..60cdd985217f0b958663b59622f7cd74323af582 100644 (file)
@@ -50,6 +50,7 @@ PATCHES=(
        "${WORKDIR}/${P}-fix-buildsystem.patch"
        "${FILESDIR}/${P}-qt-5.11.patch"
        "${FILESDIR}/${P}-qtsingleapplication.patch"
+       "${FILESDIR}/${P}-pch.patch"
 )
 
 S="${WORKDIR}/MuseScore-${PV}"