app-backup/buttersink: New package
authorautomorphism88 <adebeus@gmail.com>
Fri, 26 May 2017 02:05:24 +0000 (19:05 -0700)
committerMichał Górny <mgorny@gentoo.org>
Sat, 27 May 2017 21:45:25 +0000 (23:45 +0200)
Buttersink is a python-based, rsync-like utility for btrfs snapshots which
uses btrfs send/receive.

Bug: https://bugs.gentoo.org/619710
Closes: https://github.com/gentoo/gentoo/pull/4763

app-backup/buttersink/Manifest [new file with mode: 0644]
app-backup/buttersink/buttersink-0.6.8.ebuild [new file with mode: 0644]
app-backup/buttersink/buttersink-9999.ebuild [new file with mode: 0644]
app-backup/buttersink/metadata.xml [new file with mode: 0644]

diff --git a/app-backup/buttersink/Manifest b/app-backup/buttersink/Manifest
new file mode 100644 (file)
index 0000000..509257d
--- /dev/null
@@ -0,0 +1 @@
+DIST buttersink-0.6.8.tar.gz 51784 SHA256 12dc5683256bc6aab5ce6db5ae40c8f565b9ad7c3da944bdba46182ae89f21d3 SHA512 52898140d983bcc6776497504191f0c1c727b24fa9543f5a5997a54ced26301ca492518094ca8770fce8064bc99dc6d3f6760e986eb66f08a758985a7a85ffff WHIRLPOOL 48e487b498cc8d827a3a5b54c5fdf019ffa5719dd925830a5f3c331344fd72e75a665a48c3cea0dc755add973f162c77916af65036ae8eef67af613eeab319ff
diff --git a/app-backup/buttersink/buttersink-0.6.8.ebuild b/app-backup/buttersink/buttersink-0.6.8.ebuild
new file mode 100644 (file)
index 0000000..44802d1
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="rsync-like utility for btrfs snapshots"
+HOMEPAGE="https://github.com/AmesCornish/buttersink"
+
+LICENSE="GPL-3"
+SLOT=0
+
+# local tests would require root and cause sandbox issues with btrfs subvolume
+# operations, and network tests would require an SSH server with root login to
+# test the SSH backend, or remote S3 for that backend
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       KEYWORDS=""
+       EGIT_REPO_URI="https://github.com/AmesCornish/buttersink"
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/AmesCornish/buttersink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+       dev-python/boto[${PYTHON_USEDEP}]
+       dev-python/crcmod[${PYTHON_USEDEP}]
+       dev-python/flake8[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+       sys-fs/btrfs-progs"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+       if [[ ${PV} == 9999 ]] ; then
+               emake makestamps buttersink/version.py
+       else
+               mkdir makestamps || die
+               echo "version = \"${PV}\"" > buttersink/version.py || die
+       fi
+       distutils-r1_python_prepare_all
+}
diff --git a/app-backup/buttersink/buttersink-9999.ebuild b/app-backup/buttersink/buttersink-9999.ebuild
new file mode 100644 (file)
index 0000000..44802d1
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="rsync-like utility for btrfs snapshots"
+HOMEPAGE="https://github.com/AmesCornish/buttersink"
+
+LICENSE="GPL-3"
+SLOT=0
+
+# local tests would require root and cause sandbox issues with btrfs subvolume
+# operations, and network tests would require an SSH server with root login to
+# test the SSH backend, or remote S3 for that backend
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       KEYWORDS=""
+       EGIT_REPO_URI="https://github.com/AmesCornish/buttersink"
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/AmesCornish/buttersink/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RDEPEND="${PYTHON_DEPS}
+       dev-python/boto[${PYTHON_USEDEP}]
+       dev-python/crcmod[${PYTHON_USEDEP}]
+       dev-python/flake8[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+       sys-fs/btrfs-progs"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+       if [[ ${PV} == 9999 ]] ; then
+               emake makestamps buttersink/version.py
+       else
+               mkdir makestamps || die
+               echo "version = \"${PV}\"" > buttersink/version.py || die
+       fi
+       distutils-r1_python_prepare_all
+}
diff --git a/app-backup/buttersink/metadata.xml b/app-backup/buttersink/metadata.xml
new file mode 100644 (file)
index 0000000..d80abca
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>adebeus@gmail.com</email>
+  </maintainer>
+  <maintainer type="project">
+    <email>proxy-maint@gentoo.org</email>
+  </maintainer>
+  <longdescription>rsync-like utility for btrfs snapshots</longdescription>
+</pkgmetadata>