dev-python/keyrings_alt: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:40:19 +0000 (21:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 21:50:35 +0000 (22:50 +0100)
dev-python/keyrings_alt/Manifest
dev-python/keyrings_alt/keyrings_alt-2.2.ebuild [deleted file]

index c7212d93e676caeeab489c71fd88c93c9a36df05..76a1ab84809cc5a2e64fd2f3bf24353aeac6e86d 100644 (file)
@@ -1,2 +1 @@
-DIST keyrings.alt-2.2.tar.gz 26121 BLAKE2B 7b8967d15341e3fd0cc4a7b288688bcd3fb87d4f1a8ea34b70d23d0521794a2e5aa74829bf998d92ae4af3137e8f4e4654c8edc39b77612e61e9945538ee0428 SHA512 28d29c1f3f0a9612baa61d4506f0ac0782105a0c04ca2d9be63bd3106c82c2478487a42f2d5396d2f5e5d7205ae4f2d43221dba6ce6587e6e807d597984c833b
 DIST keyrings.alt-2.3.tar.gz 26170 BLAKE2B 5459bfbde787b82021c04394ec475a406805a97cf3ac5691aaa654790800b155291500946f29eb12cd0ae33061c0b38ca65c5733ca144e75e9047381d86ee2d9 SHA512 593194f0b3e64ebab9950b1ee674e43afecf6410110e7c683cdccaa121eaaff864ef07763363c0b0ac25b94e913d6ba2e1bb1ebb428ba14e81e3c29335b81807
diff --git a/dev-python/keyrings_alt/keyrings_alt-2.2.ebuild b/dev-python/keyrings_alt/keyrings_alt-2.2.ebuild
deleted file mode 100644 (file)
index d7f475c..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN/_/.}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Alternate keyring implementations"
-HOMEPAGE="https://github.com/jaraco/keyrings.alt http://pypi.python.org/pypi/keyrings.alt"
-SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/fs-0.5[${PYTHON_USEDEP}]
-               <dev-python/fs-2[${PYTHON_USEDEP}]
-               dev-python/gdata[$(python_gen_usedep 'python2*')]
-               dev-python/keyczar[$(python_gen_usedep 'python2*')]
-               dev-python/pycrypto[$(python_gen_usedep 'python*')]
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-       )"
-
-S=${WORKDIR}/${MY_P}
-
-# Multiple failures
-RESTRICT=test
-
-python_prepare_all() {
-       sed \
-               -e "s:find_packages():find_packages(exclude=['tests']):g" \
-               -i setup.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -v -v || die
-}