dev-ros/message_to_tf: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:45:21 +0000 (10:45 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 24 Sep 2015 08:45:21 +0000 (10:45 +0200)
Package-Manager: portage-2.2.21

dev-ros/message_to_tf/Manifest [new file with mode: 0644]
dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild [new file with mode: 0644]
dev-ros/message_to_tf/message_to_tf-9999.ebuild [new file with mode: 0644]
dev-ros/message_to_tf/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/message_to_tf/Manifest b/dev-ros/message_to_tf/Manifest
new file mode 100644 (file)
index 0000000..bb99c54
--- /dev/null
@@ -0,0 +1 @@
+DIST hector_localization-0.2.0.tar.gz 70999 SHA256 e0b01a8d1d285086e4bb738346f5d37ce188f12197bb10e75d66ac0770fc2f18 SHA512 5eab4f1861bbf1f755595700b9cb7e7f3fd1231ac9fe95f7a6f9f22c6d96045ebcecdf01b81464888b8a263fab585eb7d19682b1cc5aab6fa8809f25e7913739 WHIRLPOOL af642d3458d380c18985aa88e10625b4e7f0ae94a8bfaf9d8d4f1e38fa764785a9c95d551c4b0412c0c91649d8d3768a8cc4774fa761b8fce6ca7d21db374dd7
diff --git a/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..4c0669f
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/tf
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/topic_tools
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/message_to_tf-9999.ebuild b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
new file mode 100644 (file)
index 0000000..4c0669f
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/tf
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/topic_tools
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/metadata.xml b/dev-ros/message_to_tf/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>