x11-wm/2bwm: new package
authorJake Lilly <lillyjsm@gmail.com>
Thu, 17 Oct 2019 03:44:43 +0000 (23:44 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 19 Feb 2020 13:32:19 +0000 (15:32 +0200)
A fast, floating window manager

Bug: https://bugs.gentoo.org/697904
Signed-off-by: Jake Lilly <lillyjsm@gmail.com>
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/13321
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-wm/2bwm/2bwm-0.3.ebuild [new file with mode: 0644]
x11-wm/2bwm/2bwm-9999.ebuild [new file with mode: 0644]
x11-wm/2bwm/Manifest [new file with mode: 0644]
x11-wm/2bwm/metadata.xml [new file with mode: 0644]

diff --git a/x11-wm/2bwm/2bwm-0.3.ebuild b/x11-wm/2bwm/2bwm-0.3.ebuild
new file mode 100644 (file)
index 0000000..3f6bd23
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+               inherit git-r3
+               EGIT_REPO_URI="https://github.com/venam/2bwm.git"
+else
+               SRC_URI="https://github.com/venam/2bwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+               KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A fast, floating window manager"
+HOMEPAGE="https://github.com/venam/2bwm"
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="
+       x11-libs/libxcb
+       x11-libs/xcb-util-keysyms
+       x11-libs/xcb-util-wm
+       x11-libs/xcb-util-xrm
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       sed -i -e "s:-Os -s::" Makefile || die
+       restore_config config.h
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+       dodoc README.md
+       save_config config.h
+}
diff --git a/x11-wm/2bwm/2bwm-9999.ebuild b/x11-wm/2bwm/2bwm-9999.ebuild
new file mode 100644 (file)
index 0000000..3f6bd23
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+               inherit git-r3
+               EGIT_REPO_URI="https://github.com/venam/2bwm.git"
+else
+               SRC_URI="https://github.com/venam/2bwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+               KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A fast, floating window manager"
+HOMEPAGE="https://github.com/venam/2bwm"
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="
+       x11-libs/libxcb
+       x11-libs/xcb-util-keysyms
+       x11-libs/xcb-util-wm
+       x11-libs/xcb-util-xrm
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       sed -i -e "s:-Os -s::" Makefile || die
+       restore_config config.h
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+       dodoc README.md
+       save_config config.h
+}
diff --git a/x11-wm/2bwm/Manifest b/x11-wm/2bwm/Manifest
new file mode 100644 (file)
index 0000000..dc24b53
--- /dev/null
@@ -0,0 +1 @@
+DIST 2bwm-0.3.tar.gz 41032 BLAKE2B 41fb12dccef95221fc5b6cec1d6b740037e0842628aedea23d80980961a615a4e5cf32ee9bc6c57eec8a2e304560b5f54dec0f65462af602f70c467d8c4ebe83 SHA512 088a97e5245287890c72e2b0685f7348a4cc0fd49582893b7ce7a081f80a4d7454a3c0eadf4609589314351ded02fd8b75548019b782e797350ad5db5c939f92
diff --git a/x11-wm/2bwm/metadata.xml b/x11-wm/2bwm/metadata.xml
new file mode 100644 (file)
index 0000000..d33f238
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>lillyjsm@gmail.com</email>
+               <description>Jake Lilly</description>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">venam/2bwm</remote-id>
+       </upstream>
+</pkgmetadata>