dev-python/csv23: Remove old
authorMichał Górny <mgorny@gentoo.org>
Sat, 2 May 2020 10:32:27 +0000 (12:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 2 May 2020 10:32:52 +0000 (12:32 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/csv23/Manifest
dev-python/csv23/csv23-0.3.ebuild [deleted file]
dev-python/csv23/files/csv23-0.3-pypy3.patch [deleted file]

index 52c996b24c508cb8d8fbf3027e4492c6bc321f13..dd664de3a7ea28a5d49c8d29a2f55785df4f3977 100644 (file)
@@ -1,2 +1 @@
 DIST csv23-0.3.1.tar.gz 23959 BLAKE2B 076c1a3f52d4cf6283716c366c3b44d3cae4012ae7613e24193aa7d8e0ac96e4ee9d1325219dd90ada26970cb3fde093730224f0f9bda3cadc921d9a5465b317 SHA512 25a0e06529edab89e4541cd7622a980af2cc31eff62db9f659af5305bfdbdcd388354b38a6f725d81e2f39fb48bec7adb287bb0577e973b5709a38ff03456037
-DIST csv23-0.3.tar.gz 23625 BLAKE2B 88df927acb1910a2ada69cf0aa8855a2cda93a006e05cfa270ee86ddbea3a5fa4df52607d320fcdecd67ff3e4e5a0f900f74bbd56e75b5e44baa46ba9d26836a SHA512 7581aef25878d2c6f7aaea4cfd8af8c2062a3d18469c176a9a09513beac34299e9456f77581025e207a814311bad7becd621ebf4e0f759a8f7ca16f55fd2731f
diff --git a/dev-python/csv23/csv23-0.3.ebuild b/dev-python/csv23/csv23-0.3.ebuild
deleted file mode 100644 (file)
index 82aab4a..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="Python 2/3 unicode CSV compatibility layer"
-HOMEPAGE="
-       https://pypi.org/project/csv23/
-       https://github.com/xflr6/csv23/"
-SRC_URI="https://github.com/xflr6/csv23/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# note: upstream really uses mock at runtime
-RDEPEND="
-       $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)"
-BDEPEND="
-       test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
-       "${FILESDIR}"/${P}-pypy3.patch
-)
-
-src_prepare() {
-       sed -i -e '/--cov/d' setup.cfg || die
-       distutils-r1_src_prepare
-}
diff --git a/dev-python/csv23/files/csv23-0.3-pypy3.patch b/dev-python/csv23/files/csv23-0.3-pypy3.patch
deleted file mode 100644 (file)
index 2e1e3b2..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From cb9a4519b81daccbb54ea767829d888a6b97855a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Thu, 30 Apr 2020 11:54:31 +0200
-Subject: [PATCH] fix hashlib usage compatibility with pypy3
-
-PyPy3's hashlib fails when passed a memoryview object (i.e.
-BytesIO.getbuffer()).  Convert it to bytes instead in order to fix
-compatibility.  While this isn't necessary for CPython, it should not
-cause any issues.
-
-Also enabling testing with pypy3.  I had to switch to the newer Ubuntu
-version as well in order to avoid more bugs in old PyPy versions.
-
-PyPy3 bug: https://foss.heptapod.net/pypy/pypy/issues/3217
----
- .travis.yml        | 2 ++
- csv23/shortcuts.py | 2 +-
- tox.ini            | 2 +-
- 3 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/csv23/shortcuts.py b/csv23/shortcuts.py
-index 6eeb248..7bdb013 100644
---- a/csv23/shortcuts.py
-+++ b/csv23/shortcuts.py
-@@ -206,7 +206,7 @@ def write_csv(file, rows, header=None, dialect=DIALECT, encoding=ENCODING,
-                 buf = f.buffer
-                 for rows in iterslices(rows, 1000):
-                     writer.writerows(rows)
--                    hashsum.update(buf.getbuffer())
-+                    hashsum.update(bytes(buf.getbuffer()))
-                     # NOTE: f.truncate(0) would prepend zero-bytes
-                     f.seek(0)
-                     f.truncate()
-diff --git a/tox.ini b/tox.ini
-index 2a234b3..89a4432 100644
---- a/tox.ini
-+++ b/tox.ini
-@@ -1,5 +1,5 @@
- [tox]
--envlist = py{27,35,36,37,38}
-+envlist = py{27,35,36,37,38},pypy3
- skip_missing_interpreters = true
- [testenv]