dev-libs/appstream: Fix install issue w/ meson
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 18 May 2018 16:43:46 +0000 (18:43 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 18 May 2018 16:44:11 +0000 (18:44 +0200)
Thanks-to: David Haller <gentoo@dhaller.de>
Closes: https://bugs.gentoo.org/640916
Package-Manager: Portage-2.3.38, Repoman-2.3.9

dev-libs/appstream/appstream-0.11.5.ebuild
dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch [new file with mode: 0644]

index 227ab977dc59e0efb52695ee7b2a1f18459d952e..bf4e52ace68bd28d948ad9c5099fc504c5ef453c 100644 (file)
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
        )
 "
 
+PATCHES=( "${FILESDIR}/${P}-fix-meson-po.patch" )
+
 src_configure() {
        xdg_environment_reset
 
diff --git a/dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch b/dev-libs/appstream/files/appstream-0.11.5-fix-meson-po.patch
new file mode 100644 (file)
index 0000000..2a37662
--- /dev/null
@@ -0,0 +1,14 @@
+Gentoo-bug: https://bugs.gentoo.org/640916
+Thanks-to: David Haller <gentoo@dhaller.de>
+
+--- a/po/meson.build   2017-09-04 18:09:52.000000000 +0200
++++ b/po/meson.build   2018-05-15 12:24:42.000000000 +0200
+@@ -21,7 +21,7 @@
+         'find ' + meson.current_source_dir() +
+         ' -type f' +
+         ' -iname "*.po"' +
+-        ' -printf \'%f\\n\'' +
++        ' -printf \'%f\n\'' +
+         ' | grep -oP \'.*(?=[.])\' | sort' +
+         ' > ' + join_paths(meson.current_source_dir(), 'LINGUAS')
+     ]