dev-util/ninja-ide: rm old
authorJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 23:06:30 +0000 (01:06 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 23:06:30 +0000 (01:06 +0200)
dev-util/ninja-ide/Manifest
dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch [deleted file]
dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch [deleted file]
dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch [deleted file]
dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch [deleted file]
dev-util/ninja-ide/files/ninja-ide-2.2-version.patch [deleted file]
dev-util/ninja-ide/ninja-ide-2.1.1-r3.ebuild [deleted file]
dev-util/ninja-ide/ninja-ide-2.1.1-r5.ebuild [deleted file]
dev-util/ninja-ide/ninja-ide-2.2.ebuild [deleted file]

index 256a7610c50d7229a1ae465b51e98a0063551c23..c5be352ff9a47ed781a9fdada9a7be4225745660 100644 (file)
@@ -1,3 +1 @@
-DIST ninja-ide-2.1.1.tar.gz 737456 SHA256 534a891dfdaa262fd6465d2d72672eb29e494401968ba31c483f9eab31f3d5a8 SHA512 4ecc9e09ce9e68fa3a883f326a59d6c5fc2c52e2b8e936da0d3c57974b76ce11d1c171bcbce29ab676818efedab10bf282d28e2d43eed4c00d1b9d1d1807e48c WHIRLPOOL 7b42097df4725b3747e6c774c1ff206dae0344f860ffea1ac8bc2212a2042cfb66b8f33a799c395ed58bbbd8348f5045e09720f549b0974b65ba80509980d1af
-DIST ninja-ide-2.2.tar.gz 763910 SHA256 2f2a46f33a81229ebc63b34cc52e76625ce62a9be0f107c4c3b91ba3c159a409 SHA512 311fd94a2595ff962cd41bc7e84dd1d9d9b8feb2ea0ffdbbbd52735661f48d0a3e97eaca50a83100f66e37043b9554ca67fdd64853111c85b3a54c085b953bcb WHIRLPOOL 735cbedae901a1ce298cde67f26288f03df621fb698660eb9e7431e314a064473f12fe3a6ac89e7bc2352e2ca2b77d5e3ac4f6b4d00fc250183cf0d552d8f559
 DIST ninja-ide-2.3.tar.gz 650762 SHA256 79012ba8e526e126d54ba7b70fa6fcf61dfadb478624a74c299a0740c170d9ac SHA512 c449620c603060cb9dcc64ffa8c5a778a3993501c906b89a8ece1691ec85504521c893b03b8536c16d9a3e20c10fbc29b0fbfdf57250eb68a7284dca54dbaca9 WHIRLPOOL 79182e28bbef2592ef9ffeae301d0a48a87765121169e505fbe1364961e3286425d2a44b1d4e637bf3ccdea22f4cce3333a55ab8a855a80f1b167e3220ea84ca
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch b/dev-util/ninja-ide/files/ninja-ide-2.1.1-lang.patch
deleted file mode 100644 (file)
index a374ded..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Tue Oct  9 20:22:45 UTC 2012
-Subject: build system
-
-add install rules for translations
-
---- setup.py
-+++ setup.py
-@@ -95,14 +95,15 @@
-     # include all resources
-     "include_package_data": True,
--    "package_data": {'': ['*.png', '*.json', '*.qss',
--        '*.js', '*.html', '*.css']},
-+    "package_data": {'': ['*.png', '*.gif', '*.jpg', '*.json', '*.qss',
-+        '*.js', '*.html', '*.css', '*.qm']},
-     # include ninja pkg and setup the run script
-     "packages": find_packages() + [
-         'ninja_ide/addins',
-         'ninja_ide/addins/syntax',
-         'ninja_ide/addins/theme',
-+        'ninja_ide/addins/lang',
-         'ninja_ide/doc',
-         'ninja_ide/doc/css',
-         'ninja_ide/doc/img',
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch b/dev-util/ninja-ide/files/ninja-ide-2.1.1-syntaxhighlighting.patch
deleted file mode 100644 (file)
index f3eb64b..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-https://github.com/ninja-ide/ninja-ide/commit/f19cffa29646f1f9bc015597080b8ebc0ed83530.patch
-https://github.com/ninja-ide/ninja-ide/commit/c722e86c4e497efac56de674c47d5e094ea4c5c5.patch
-
-backported by hasufell@gentoo.org for 2.1.1
-
---- ninja_ide/gui/editor/highlighter.py
-+++ ninja_ide/gui/editor/highlighter.py
-@@ -276,7 +276,7 @@
-         hls = []
-         block = self.currentBlock()
-         user_data = block.userData()
--        if user_data is None:
-+        if user_data is None or not isinstance(user_data, SyntaxUserData):
-             user_data = SyntaxUserData(False)
-         user_data.clear_data()
-         block_number = block.blockNumber()
-@@ -321,7 +321,7 @@
-         hls = []
-         block = self.currentBlock()
-         user_data = block.userData()
--        if user_data is None:
-+        if user_data is None or not isinstance(user_data, SyntaxUserData):
-             user_data = SyntaxUserData(False)
-         user_data.clear_data()
-         block_number = block.blockNumber()
-@@ -409,7 +409,7 @@
-         block = self.document().begin()
-         while block.isValid():
-             user_data = block.userData()
--            if (user_data is not None) and (user_data.error == True):
-+            if (user_data is not None) and isinstance(user_data, SyntaxUserData) and (user_data.error == True):
-                 errors_lines.append(block.blockNumber())
-             block = block.next()
-         return errors_lines
-@@ -462,7 +462,7 @@
-                ((st_fmt == STYLES['comment']) and
-                (self.previousBlockState() != 0))) and \
-                 (len(start_collides) == 0):
--                if user_data is not None:
-+                if user_data is not None and isinstance(user_data, SyntaxUserData):
-                     style = highlight_errors(style, user_data)
-                 self.setFormat(start, length, style)
-             else:
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-python2_6.patch
deleted file mode 100644 (file)
index c01465d..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Wed Apr 24 21:05:44 UTC 2013
-Subject: fix compatibility with python:2.6
-
---- ninja_ide/core/file_manager.py
-+++ ninja_ide/core/file_manager.py
-@@ -26,7 +26,7 @@
- from ninja_ide.core import settings
--if sys.version_info.major == 3:
-+if sys.version_info[0] == 3:
-     python3 = True
- else:
-     python3 = False
-
---- ninja_ide/gui/editor/editor.py
-+++ ninja_ide/gui/editor/editor.py
-@@ -68,7 +68,7 @@
- logger = NinjaLogger('ninja_ide.gui.editor.editor')
--if sys.version_info.major == 3:
-+if sys.version_info[0] == 3:
-     python3 = True
- else:
-     python3 = False
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-syntax.patch
deleted file mode 100644 (file)
index 0430b64..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
---- ninja_tests/core/examples/file_for_tests.py
-+++ ninja_tests/core/examples/file_for_tests.py
-@@ -1,4 +1,4 @@
- # -*- coding: utf-8 -*-
--print 'testing'
--print 'ñandú testing'
-+print('testing')
-+print('ñandú testing')
diff --git a/dev-util/ninja-ide/files/ninja-ide-2.2-version.patch b/dev-util/ninja-ide/files/ninja-ide-2.2-version.patch
deleted file mode 100644 (file)
index a060b2b..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-Correct package version.
-
-Patch by Aaron Burnett <awol.lordofthepants@gmail.com>
-
---- ninja_ide/__init__.py
-+++ ninja_ide/__init__.py
-@@ -29,1 +29,1 @@
--__version__ = "2.2-dev"
-+__version__ = "2.2"
diff --git a/dev-util/ninja-ide/ninja-ide-2.1.1-r3.ebuild b/dev-util/ninja-ide/ninja-ide-2.1.1-r3.ebuild
deleted file mode 100644 (file)
index 667359e..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: tests
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils gnome2-utils distutils-r1 vcs-snapshot
-
-DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
-HOMEPAGE="http://www.ninja-ide.org"
-SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
-       dev-python/PyQt4[webkit]
-       dev-python/pyinotify"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-lang.patch )
-
-python_install_all() {
-       distutils-r1_python_install_all
-       newicon -s 256 icon.png ${PN}.png
-       make_desktop_entry ${PN} "NINJA-IDE"
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}
diff --git a/dev-util/ninja-ide/ninja-ide-2.1.1-r5.ebuild b/dev-util/ninja-ide/ninja-ide-2.1.1-r5.ebuild
deleted file mode 100644 (file)
index 30d75fe..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: tests
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils gnome2-utils distutils-r1 vcs-snapshot
-
-DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
-HOMEPAGE="http://www.ninja-ide.org"
-SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-RDEPEND="
-       dev-python/PyQt4[webkit,${PYTHON_USEDEP}]
-       dev-python/pyinotify[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-lang.patch
-       "${FILESDIR}"/${P}-syntaxhighlighting.patch
-       )
-
-python_install_all() {
-       distutils-r1_python_install_all
-       newicon -s 256 icon.png ${PN}.png
-       make_desktop_entry ${PN} "NINJA-IDE"
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}
diff --git a/dev-util/ninja-ide/ninja-ide-2.2.ebuild b/dev-util/ninja-ide/ninja-ide-2.2.ebuild
deleted file mode 100644 (file)
index da92a49..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: tests
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils gnome2-utils distutils-r1 vcs-snapshot
-
-DESCRIPTION="Ninja-IDE Is Not Just Another IDE"
-HOMEPAGE="http://www.ninja-ide.org"
-SRC_URI="https://github.com/ninja-ide/ninja-ide/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="
-       dev-python/PyQt4[webkit,${PYTHON_USEDEP}]
-       dev-python/pyinotify[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-syntax.patch
-       "${FILESDIR}"/${P}-python2_6.patch
-       "${FILESDIR}"/${P}-version.patch
-)
-
-python_install_all() {
-       distutils-r1_python_install_all
-       newicon -s 256 icon.png ${PN}.png
-       make_desktop_entry ${PN} "NINJA-IDE"
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}