dev-libs/libbytesize: use python-r1
authorMike Gilbert <floppym@gentoo.org>
Sat, 4 May 2019 16:44:37 +0000 (12:44 -0400)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 07:34:51 +0000 (09:34 +0200)
Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/libbytesize/libbytesize-2.0-r2.ebuild [moved from dev-libs/libbytesize/libbytesize-2.0-r1.ebuild with 72% similarity]

similarity index 72%
rename from dev-libs/libbytesize/libbytesize-2.0-r1.ebuild
rename to dev-libs/libbytesize/libbytesize-2.0-r2.ebuild
index 6da71cd71480fa1bd019f1a8470dbed1b0212b02..bfb8a984b132207d7973b689f3dff3af5674df7b 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python3_{5,6,7} )
 
-inherit autotools python-single-r1
+inherit autotools python-r1
 
 DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
 HOMEPAGE="https://github.com/storaged-project/libbytesize"
@@ -44,17 +44,39 @@ src_prepare() {
        eautoreconf
 }
 
+python_do() {
+       if use python; then
+               python_foreach_impl run_in_build_dir "$@"
+       else
+               "$@"
+       fi
+}
+
 src_configure() {
        local myeconfargs=(
                $(use_with doc gtk-doc)
                $(use_with python python3)
                $(use_with tools)
        )
-       econf "${myeconfargs[@]}"
+       local ECONF_SOURCE="${S}"
+       python_do econf "${myeconfargs[@]}"
 }
 
-src_install() {
-       default
+src_compile() {
+       python_do emake
+}
+
+src_test() {
+       python_do emake check
+}
+
+install_helper() {
+       emake DESTDIR="${D}" install
        use python && python_optimize
-       find "${ED}" -name "*.la*" -delete || die
+}
+
+src_install() {
+       python_do install_helper
+       einstalldocs
+       find "${ED}" -name "*.la" -type f -delete || die
 }