dev-python/wrapt: Improve use of distutils_enable_sphinx
authorSebastian Pipping <sping@gentoo.org>
Fri, 6 Mar 2020 16:32:45 +0000 (17:32 +0100)
committerSebastian Pipping <sping@gentoo.org>
Fri, 6 Mar 2020 16:32:45 +0000 (17:32 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

dev-python/wrapt/wrapt-1.12.0.ebuild

index 8a24a98651e8c656019b952a79105ee6564aa715..978e8e79af62773c3216f95ae564a4b3e8f422f1 100644 (file)
@@ -16,10 +16,8 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
 
-DEPEND="doc? ( dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )"
-
 distutils_enable_tests pytest
-distutils_enable_sphinx docs --no-autodoc
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
 
 python_compile() {
        local WRAPT_EXTENSIONS=true