app-editors/xemacs: Use xdg_desktop_database_update
authorMats Lidell <matsl@gentoo.org>
Sun, 10 Dec 2017 21:43:53 +0000 (22:43 +0100)
committerMats Lidell <matsl@gentoo.org>
Sun, 10 Dec 2017 21:44:36 +0000 (22:44 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-editors/xemacs/xemacs-21.4.24-r1.ebuild
app-editors/xemacs/xemacs-21.4.24.ebuild
app-editors/xemacs/xemacs-21.5.34-r4.ebuild

index 980a68d80e3d912aa40fe9e1bd3791f60ecbb7fd..6975de5d4292b097a74c3f8e6d76c7cb80fe4454 100644 (file)
@@ -7,7 +7,7 @@
 EAPI="5"
 
 WANT_AUTOCONF="2.1"
-inherit autotools eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs xdg-utils
 
 DESCRIPTION="highly customizable open source text editor and application development system"
 HOMEPAGE="http://www.xemacs.org/"
@@ -233,9 +233,11 @@ src_install() {
 pkg_postinst() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 }
 
 pkg_postrm() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 }
index 4c1eaa52fd037bacc83485cc3bdedd77c811c7f8..a1297fa36999c5b955133d56cae906e989628c49 100644 (file)
@@ -7,7 +7,7 @@
 EAPI="5"
 
 WANT_AUTOCONF="2.1"
-inherit autotools eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs xdg-utils
 
 DESCRIPTION="highly customizable open source text editor and application development system"
 HOMEPAGE="http://www.xemacs.org/"
@@ -235,9 +235,11 @@ src_install() {
 pkg_postinst() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 }
 
 pkg_postrm() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 }
index d806967cce40537efea49deaf9f5715cc621013c..c060855e59246091382642afe9db8ed88da7458b 100644 (file)
@@ -7,7 +7,7 @@
 EAPI=5
 
 WANT_AUTOCONF="2.5"
-inherit eutils flag-o-matic multilib
+inherit eutils flag-o-matic multilib xdg-utils
 
 DESCRIPTION="highly customizable open source text editor and application development system"
 HOMEPAGE="http://www.xemacs.org/"
@@ -235,6 +235,7 @@ src_install() {
 pkg_postinst() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 
        einfo "If you are upgrading from XEmacs 21.4 you should note the following"
        einfo "incompatibilities:"
@@ -252,4 +253,5 @@ pkg_postinst() {
 pkg_postrm() {
        eselect emacs update ifunset
        eselect gnuclient update ifunset
+       xdg_desktop_database_update
 }