sci-chemistry/ParmEd: Initial version
authorAlexey Shvetsov <alexxy@gentoo.org>
Wed, 5 Apr 2017 19:47:09 +0000 (22:47 +0300)
committerAlexey Shvetsov <alexxy@gentoo.org>
Wed, 5 Apr 2017 19:47:09 +0000 (22:47 +0300)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-chemistry/ParmEd/Manifest [new file with mode: 0644]
sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild [new file with mode: 0644]
sci-chemistry/ParmEd/metadata.xml [new file with mode: 0644]

diff --git a/sci-chemistry/ParmEd/Manifest b/sci-chemistry/ParmEd/Manifest
new file mode 100644 (file)
index 0000000..59f6595
--- /dev/null
@@ -0,0 +1 @@
+DIST ParmEd-2.7.3.tar.gz 34494858 SHA256 56b3097625be3a5037a5b3d7c4d9467a97f0dd44fea79cf2873f0e56d3409975 SHA512 a3444f915e188bcc924f28b6b4235246e2c063ae98881c48f6e13ebc685d085d6a1bcb61b29509a343cbe58369bc6233acc20ee620c6f1d42da2033772a12e07 WHIRLPOOL 909e2c1681fa3d37c0f43e3584df27bc5af351cfdd8c3726da02a29507fe31d1551cb95cb15e8beb88c52ccf0debe3cb0e2006401e8445a829ef618e8ccddb01
diff --git a/sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild b/sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild
new file mode 100644 (file)
index 0000000..a183d0d
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+if [[ $PV = *9999* ]]; then
+       scm_eclass=git-2
+       EGIT_REPO_URI="
+               git://github.com/${PN}/${PN}.git
+               https://github.com/${PN}/${PN}.git"
+       SRC_URI=""
+       KEYWORDS=""
+else
+       scm_eclass=vcs-snapshot
+       SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Parameter/topology editor and molecular simulator"
+HOMEPAGE="http://parmed.github.io/ParmEd"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       dev-python/numpy[${PYTHON_USEDEP}]
+       sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       sed \
+               -e "/delfile/d" \
+               -e "/deldir/d" \
+               -i setup.py || die
+       distutils-r1_src_prepare
+}
diff --git a/sci-chemistry/ParmEd/metadata.xml b/sci-chemistry/ParmEd/metadata.xml
new file mode 100644 (file)
index 0000000..d10bde2
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>alexxy@gentoo.org</email>
+    <name>Alexey Shvetsov</name>
+  </maintainer>
+<maintainer type="project">
+    <email>sci-chemistry@gentoo.org</email>
+    <name>Gentoo Chemistry Project</name>
+  </maintainer>
+</pkgmetadata>