net-libs/socket_wrapper: Workaround for bug #558340
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 28 Aug 2015 14:05:48 +0000 (16:05 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 28 Aug 2015 14:14:42 +0000 (16:14 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-libs/socket_wrapper/socket_wrapper-1.1.3.ebuild
net-libs/socket_wrapper/socket_wrapper-1.1.4.ebuild

index 640369fbb2ebdfbba3fbe3f67c387ec714ad7446..6d917488a1930156e7eb41b930527acd175d4305 100644 (file)
@@ -16,3 +16,10 @@ IUSE="test"
 
 DEPEND=""
 RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+       local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+       cmake-utils_src_configure
+}
index 51b698f907536e5deddc5520ad1058d009a7ba4f..d68a3de38e5b695af1da1a2d0d69e7a70a424332 100644 (file)
@@ -16,3 +16,10 @@ IUSE="test"
 
 DEPEND=""
 RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+       local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+       cmake-utils_src_configure
+}