dev-util/diffoscope: bump up to 145
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 May 2020 11:17:02 +0000 (12:17 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 24 May 2020 11:17:09 +0000 (12:17 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/diffoscope/Manifest
dev-util/diffoscope/diffoscope-145.ebuild [new file with mode: 0644]

index a1af1aac9ff5eb0dc329ed9c4071652a19707b70..fe0fb6e684b784bfedb1dceca1ff87d574b15251 100644 (file)
@@ -1,2 +1,3 @@
 DIST diffoscope-143.tar.gz 1569293 BLAKE2B 38a9561f8f7ee2cc852b8363daf725c95bfcba26cc408f0154d77023222dd62dd9a6d5a6b255ea84542ed02a727a26f843facda0c70a585e3e4c5d05096dc96d SHA512 a511efe2eebe079f2980809318eb264890b14f13af69bbe8e394c39774063f37c4c6558a1a9f46aaf22f6627603fadcc416eeda8cf005f80860f4591bfa1f81e
 DIST diffoscope-144.tar.gz 1569864 BLAKE2B 951a9322a92b52b148bfe39f1aea6588b069fa40463b2a59feacf8f3b57a8ab297e7637b8209a40376d9c858dea1a58f3fc49b5e0cceadde64f8f6f5f7a5e1b2 SHA512 1ef5fc79c3889b0cbb9a69f27912b19fea61828db91185882b19bf0ef3932d66b911d4b9869d72fd4e19efb90743dc8645ed46fd1f887f5fc117bcdeb13a5c10
+DIST diffoscope-145.tar.gz 1570621 BLAKE2B f40ecde3e5392559c62c3e9c4dc37b1255f8db22e0a21fb2228995d9da8e977fd88fbbdd44a4cbdb75762cc56afba801de2f235a9f348fcdc4f3e77c7c665ceb SHA512 400d40b7a6a00b246630d8ab251dc9fc1a1c0ca117102ef13f793cff63dfa551f4b77081f6061c47bf87d8de65fef406d34a8b63692c5b129526132c01b1b082
diff --git a/dev-util/diffoscope/diffoscope-145.ebuild b/dev-util/diffoscope/diffoscope-145.ebuild
new file mode 100644 (file)
index 0000000..63058ee
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
+HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
+find gettext gif gpg gzip haskell hdf5 hex imagemagick iso java llvm
+mono opendocument pascal pdf postscript R rpm sqlite squashfs
+ssh tar tcpdump xz zip zstd"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
+       dev-python/libarchive-c[${PYTHON_USEDEP}]
+       dev-python/distro[${PYTHON_USEDEP}]
+       acl? ( sys-apps/acl )
+       binutils? ( sys-devel/binutils )
+       bzip2? ( app-arch/bzip2 )
+       libcaca? ( media-libs/libcaca )
+       colord? ( x11-misc/colord )
+       cpio? ( app-arch/cpio )
+       diff? ( sys-apps/diffutils )
+       docx? ( app-text/docx2txt )
+       dtc? ( sys-apps/dtc )
+       e2fsprogs? ( sys-fs/e2fsprogs )
+       file? ( sys-apps/file )
+       find? ( sys-apps/findutils )
+       gettext? ( sys-devel/gettext )
+       gif? ( media-libs/giflib )
+       gpg? ( app-crypt/gnupg )
+       gzip? ( app-arch/gzip )
+       haskell? ( dev-lang/ghc )
+       hdf5? ( sci-libs/hdf5 )
+       hex? ( app-editors/vim-core )
+       imagemagick? ( media-gfx/imagemagick )
+       iso? ( virtual/cdrtools )
+       java? ( virtual/jdk )
+       llvm? ( sys-devel/llvm )
+       mono? ( dev-lang/mono )
+       opendocument? ( app-text/odt2txt )
+       pascal? ( dev-lang/fpc )
+       pdf? (
+               app-text/pdftk
+               app-text/poppler
+               dev-python/PyPDF2[${PYTHON_USEDEP}]
+       )
+       postscript? ( app-text/ghostscript-gpl )
+       R? ( dev-lang/R )
+       rpm? ( app-arch/rpm )
+       sqlite? ( dev-db/sqlite:3 )
+       squashfs? ( sys-fs/squashfs-tools )
+       ssh? ( net-misc/openssh )
+       tar? ( app-arch/tar )
+       tcpdump? ( net-analyzer/tcpdump )
+       xz? ( app-arch/xz-utils )
+       zip? ( app-arch/unzip )
+       zstd? ( app-arch/zstd )
+"
+# Presence if filemagic's magic.py breaks imports
+# of dev-python/python-magic: https://bugs.gentoo.org/716482
+RDEPEND+=" !dev-python/filemagic"