net-analyzer/icinga2: cleaner minimal usage
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 2 Sep 2015 03:55:19 +0000 (22:55 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 2 Sep 2015 03:55:19 +0000 (22:55 -0500)
Package-Manager: portage-2.2.20.1

net-analyzer/icinga2/icinga2-2.3.9.ebuild

index c996c274e9968bf97d5b274c7a1f757b63e9c984..ac3a260334cf88d714bc2290763a83f79aa140d4 100644 (file)
@@ -61,6 +61,12 @@ src_configure() {
                -DICINGA2_COMMAND_GROUP=icingacmd
                -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
        )
+       if use minimal; then
+               mycmakeargs+=(
+                       -DICINGA2_WITH_MYSQL=OFF
+                       -DICINGA2_WITH_PGSQL=OFF
+               )
+       fi
        if use postgres; then
                mycmakeargs+=(
                        -DICINGA2_WITH_PGSQL=ON