dev-python/sentinels: sentinel class (new package)
authorVictor Payno <vpayno+gentoo@gmail.com>
Sat, 4 Apr 2020 00:54:41 +0000 (17:54 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 5 Apr 2020 22:04:24 +0000 (15:04 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15220
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-python/sentinels/Manifest [new file with mode: 0644]
dev-python/sentinels/metadata.xml [new file with mode: 0644]
dev-python/sentinels/sentinels-1.0.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/sentinels/Manifest b/dev-python/sentinels/Manifest
new file mode 100644 (file)
index 0000000..ee2ff90
--- /dev/null
@@ -0,0 +1 @@
+DIST sentinels-1.0.0.tar.gz 4074 BLAKE2B 5fdbe488430685e24218b4c1a2ead75272c2024f6653c5f1363ee0e1180878e91ad1e6500ce8f7199b7a95f9680f427927ffa8e573fb5c7ff45ede2894a9fa9f SHA512 06aebf28a3074d377b4257ce3e07ced51425f738b3f2e3e4c1764e946137a363c6e94b247e0eb165c6c87eb749751aac36b580b9c550fe513dc0e126738e8794
diff --git a/dev-python/sentinels/metadata.xml b/dev-python/sentinels/metadata.xml
new file mode 100644 (file)
index 0000000..16f92bf
--- /dev/null
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>vpayno+gentoo@gmail.com</email>
+               <name>Victor Payno</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>gyakovlev@gentoo.org</email>
+               <name>Georgy Yakovlev</name>
+       </maintainer>
+       <longdescription>
+               Sentinels are objects with special meanings. They can be thought of as singletons, but they service the need of having 'special' values in your code, that have special meanings.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">sentinels</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/sentinels/sentinels-1.0.0.ebuild b/dev-python/sentinels/sentinels-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..664a217
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Sentinels class which are objects with special meanings."
+HOMEPAGE="https://pypi.org/project/sentinels"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests nose