app-crypt/tpm2-tss-engine: Remove libressl support
authorSalah Coronya <salah.coronya@gmail.com>
Thu, 20 Feb 2020 02:06:07 +0000 (20:06 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 26 Feb 2020 16:17:25 +0000 (18:17 +0200)
Libressl dropped all engine support in 2.3.0 .

Closes: https://bugs.gentoo.org/692558
Closes: https://bugs.gentoo.org/687132
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build-add-disable-defaultflags.patch [moved from app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch with 78% similarity]
app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch [deleted file]
app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.1.ebuild

similarity index 78%
rename from app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build.patch
rename to app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-build-add-disable-defaultflags.patch
index aa2b2e4e4fd34fdcb38cbceb86fdc948b285f323..7556a80600da016d01ce6b383e14a5581ed82993 100644 (file)
@@ -1,22 +1,20 @@
-From 92aee12fbd246461a22925dd054c4d6394c4fdf5 Mon Sep 17 00:00:00 2001
+From 56cc4110e1ef0667ff248a689c50803c2ec4312b Mon Sep 17 00:00:00 2001
 From: Alon Bar-Lev <alon.barlev@gmail.com>
 Date: Fri, 31 May 2019 02:30:37 +0300
-Subject: [PATCH] build: add --disable-defaultflags
+Subject: [PATCH 2/3] build: add --disable-defaultflags
 
 Align with tpm2-tss to allow downstream to provide flags.
 
 Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
 ---
- configure.ac | 42 +++++++++++++++++++++++++-----------------
- 1 file changed, 25 insertions(+), 17 deletions(-)
-
-https://github.com/tpm2-software/tpm2-tss-engine/pull/117
+ configure.ac | 41 ++++++++++++++++++++++++-----------------
+ 1 file changed, 24 insertions(+), 17 deletions(-)
 
 diff --git a/configure.ac b/configure.ac
-index f3a399c..f59cfaf 100644
+index d14c4d7..3ee45c5 100644
 --- a/configure.ac
 +++ b/configure.ac
-@@ -80,23 +80,31 @@ AS_IF([test "x$enable_tctienvvar" = xyes], [AC_DEFINE([ENABLE_TCTIENVVAR], [1])]
+@@ -84,23 +84,30 @@ AC_ARG_ENABLE([tctienvvar],
  
  AC_CONFIG_FILES([Makefile])
  
@@ -39,8 +37,7 @@ index f3a399c..f59cfaf 100644
 -AX_ADD_LINK_FLAG([-Wl,-z,relro])
 +AC_ARG_ENABLE([defaultflags],
 +              [AS_HELP_STRING([--disable-defaultflags],
-+                              [Disable default preprocessor, compiler, and linker flags.])],
-+              [enable_defaultflags=$enableval],
++                              [Disable default preprocessor, compiler, and linker flags.])],,
 +              [enable_defaultflags=yes])
 +AS_IF([test "x$enable_defaultflags" = "xyes"],
 +      [
@@ -66,5 +63,5 @@ index f3a399c..f59cfaf 100644
  AX_CODE_COVERAGE
  m4_ifdef([_AX_CODE_COVERAGE_RULES],
 -- 
-2.21.0
+2.24.1
 
diff --git a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.0.1-libressl.patch
deleted file mode 100644 (file)
index 66bb68e..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From deb2b6697babf99aaf3f64b342ce414b48638ea3 Mon Sep 17 00:00:00 2001
-From: Alon Bar-Lev <alon.barlev@gmail.com>
-Date: Fri, 31 May 2019 20:36:47 +0300
-Subject: [PATCH] build: libressl fix incomplete type
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-src/tpm2-tss-engine-rand.c:90:1: error: variable ‘rand_methods’ has initializer but incomplete type
-   90 | static RAND_METHOD rand_methods = {
-      | ^~~~~~
-src/tpm2-tss-engine-rand.c:91:5: warning: excess elements in struct initializer
-
-Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
----
- src/tpm2-tss-engine-rand.c | 1 +
- 1 file changed, 1 insertion(+)
-
-https://github.com/tpm2-software/tpm2-tss-engine/pull/120
-
-diff --git a/src/tpm2-tss-engine-rand.c b/src/tpm2-tss-engine-rand.c
-index 50d5661..86980a5 100644
---- a/src/tpm2-tss-engine-rand.c
-+++ b/src/tpm2-tss-engine-rand.c
-@@ -32,6 +32,7 @@
- #include <string.h>
- #include <openssl/engine.h>
-+#include <openssl/rand.h>
- #include <tss2/tss2_mu.h>
- #include <tss2/tss2_esys.h>
--- 
-2.21.0
-
index f1b1b5c2ca02c8ed0a544c662a14c0ba84c55558..8bdced04657f29ec7bd6e5879d8ec38ff17fb0be 100644 (file)
@@ -12,19 +12,17 @@ SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.ta
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="libressl test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND=">=app-crypt/tpm2-tss-2.2.2:=
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )"
+       dev-libs/openssl:0"
 DEPEND="${RDEPEND}
        test? ( dev-util/cmocka )"
 BDEPEND="virtual/pkgconfig"
 
 PATCHES=(
-       "${FILESDIR}/${P}-build.patch"
-       "${FILESDIR}/${P}-libressl.patch"
+       "${FILESDIR}/${P}-build-add-disable-defaultflags.patch"
 )
 
 src_prepare() {