dev-ada/xmlada: Respect ADA (env vars)
authorTupone Alfredo <tupone@gentoo.org>
Tue, 20 Jun 2017 19:29:58 +0000 (21:29 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 20 Jun 2017 19:29:58 +0000 (21:29 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.1

dev-ada/xmlada/files/xmlada-2016-gentoo.patch
dev-ada/xmlada/files/xmlada-2017-gentoo.patch [new file with mode: 0644]
dev-ada/xmlada/xmlada-2016.ebuild
dev-ada/xmlada/xmlada-2017.ebuild
dev-ada/xmlada/xmlada-9999.ebuild

index 7c28a02289f8566fe24dd08146c786667c4c2186..820fa526edcc8cf6678107c017c3afa865d1aa28 100644 (file)
  
  # Rebuild the tests (and not the XML/Ada code itself)
  test: force
+--- xmlada-gpl-2016-src/shared.gpr.in.old      2017-06-20 21:22:08.312775803 +0200
++++ xmlada-gpl-2016-src/shared.gpr.in  2017-06-20 21:22:47.486201843 +0200
+@@ -76,6 +76,7 @@
+          when "profile" =>
+             for Switches ("Ada") use warnings & ("-g", "-pg");
+       end case;
++      for Driver ("Ada") use External ("ADA", "gcc");
+    end compiler;
+    package binder is
diff --git a/dev-ada/xmlada/files/xmlada-2017-gentoo.patch b/dev-ada/xmlada/files/xmlada-2017-gentoo.patch
new file mode 100644 (file)
index 0000000..cdf5da8
--- /dev/null
@@ -0,0 +1,10 @@
+--- xmlada-gpl-2016-src/shared.gpr.in.old      2017-06-20 21:22:08.312775803 +0200
++++ xmlada-gpl-2016-src/shared.gpr.in  2017-06-20 21:22:47.486201843 +0200
+@@ -76,6 +76,7 @@
+          when "profile" =>
+             for Switches ("Ada") use warnings & ("-g", "-pg");
+       end case;
++      for Driver ("Ada") use External ("ADA", "gcc");
+    end compiler;
+    package binder is
index e686d81050735372303c15914e4d756f86c8ec6f..4b64587e5d4b088404309d2211870b1e9d218774 100644 (file)
@@ -9,7 +9,8 @@ MYP=${PN}-gpl-${PV}
 
 DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
 HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0 -> ${MYP}-src.tar.gz"
+SRC_URI="http://mirrors.cdn.adacore.com/art/57399978c7a447658e0affc0 ->
+       ${MYP}-src.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
@@ -17,7 +18,7 @@ KEYWORDS="~amd64"
 IUSE="+shared static static-pic"
 REQUIRED_USE="|| ( shared static static-pic )"
 
-RDEPEND="dev-lang/gnat-gpl:="
+RDEPEND="dev-lang/gnat-gpl:*"
 DEPEND="${RDEPEND}
        dev-ada/gprbuild"
 
index 7b42b3188719b61f75027c7869535f789e5264a8..0b67a93ace6b30ba6471de662e624bf9e6a0426c 100644 (file)
@@ -18,12 +18,14 @@ KEYWORDS="~amd64"
 IUSE="+shared static static-pic"
 REQUIRED_USE="|| ( shared static static-pic )"
 
-RDEPEND="dev-lang/gnat-gpl:="
+RDEPEND="dev-lang/gnat-gpl:*"
 DEPEND="${RDEPEND}
        dev-ada/gprbuild"
 
 S="${WORKDIR}"/${MYP}-src
 
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
 src_configure () {
        econf --prefix="${D}"/usr
 }
index f5ea599e78fd10161cc85905889d6572d86f2dc5..8527add2006449eaffc1f00bdc46bda3869648ff 100644 (file)
@@ -18,7 +18,7 @@ KEYWORDS=""
 IUSE="+shared static static-pic"
 REQUIRED_USE="|| ( shared static static-pic )"
 
-RDEPEND="dev-lang/gnat-gpl:="
+RDEPEND="dev-lang/gnat-gpl:*"
 DEPEND="${RDEPEND}
        dev-ada/gprbuild"