gnome-extra/gnome-user-docs: bump to 3.34.2
authorMart Raudsepp <leio@gentoo.org>
Fri, 1 May 2020 12:27:57 +0000 (15:27 +0300)
committerMart Raudsepp <leio@gentoo.org>
Fri, 1 May 2020 12:47:53 +0000 (15:47 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-user-docs/Manifest
gnome-extra/gnome-user-docs/gnome-user-docs-3.34.2.ebuild [new file with mode: 0644]

index 3cbc5c3151bb95288b80778ab3cdc75cb9c41b1d..fc600d626c7e9dd4792e4d0465f35104af3b186c 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-user-docs-3.34.1.tar.xz 15983924 BLAKE2B 5e9c07cb1e5d33b4fc220a00e679e26d804963fa7ee8d42d4e805e8abaa1e8717028c03815ff3bd82f81d3a61fcf38b258940ec88ef2e9b1fbdf4df6d94bb8d0 SHA512 f9e65f4d0770ce97493f2eaa6b7743575e3bca3d816d0cd06ee35af99016722631086502450db5900693527a71bec9d65c97829c1486b6aff4a137a7f6016baf
+DIST gnome-user-docs-3.34.2.tar.xz 15979452 BLAKE2B cf91c33731ced37a685318ebef0948bd175670cdbfe555b1581ecac8f04b1206e4259f7a1c729e3fddc79322a1cc9cadd1e98a5f95646dc7b1afd64f0d324e9c SHA512 3e9c9e720959b758419201b9e0481ea7d352c77e9a195880f1085ba54485ccf787aaba6ef1cbf48c0a9955e879ebd5fc3d4003d195f522d35d4df047038e1fa2
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-3.34.2.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..1c83d24
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+       test? ( dev-libs/libxml2 )
+"
+# eautoreconf requires:
+#      app-text/yelp-tools
+# rebuilding translations requires:
+#      app-text/yelp-tools
+#      dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+       !test? ( test )"
+
+src_configure() {
+       # itstool is only needed for rebuilding translations
+       # xmllint is only needed for tests
+       gnome2_src_configure \
+               $(usex test "" XMLLINT=$(type -P true)) \
+               ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+       # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+       # which can take > 2 hours on a Core i7.
+       return
+}