masked version bump; clean old ebuilds
authorMichael Sterrett <mr_bones_@gentoo.org>
Sat, 16 Dec 2006 03:18:08 +0000 (03:18 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Sat, 16 Dec 2006 03:18:08 +0000 (03:18 +0000)
Package-Manager: portage-2.1.1-r2

games-strategy/wesnoth/ChangeLog
games-strategy/wesnoth/files/digest-wesnoth-1.1.14 [new file with mode: 0644]
games-strategy/wesnoth/wesnoth-1.1.14.ebuild [new file with mode: 0644]

index fdff25e93a31ed4104e61de2a7cb166cd849cfce..565547c8d200f4156aeeb70fa6a7451924e0c699 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for games-strategy/wesnoth
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.82 2006/12/06 21:07:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.83 2006/12/16 03:18:08 mr_bones_ Exp $
+
+*wesnoth-1.1.14 (16 Dec 2006)
+
+  16 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org>
+  -wesnoth-1.1.11.ebuild, -wesnoth-1.1.12.ebuild, -wesnoth-1.1.13.ebuild,
+  +wesnoth-1.1.14.ebuild:
+  masked version bump; clean old ebuilds
 
   06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> wesnoth-1.0.2.ebuild:
   Remove old virtual/x11 dependency.
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.1.14 b/games-strategy/wesnoth/files/digest-wesnoth-1.1.14
new file mode 100644 (file)
index 0000000..e441487
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9b7238f37faccf1c7be71de9475dc02b wesnoth-1.1.14.tar.gz 74509051
+RMD160 1b9d54d46d4125cbf894587994cb410681fcaad2 wesnoth-1.1.14.tar.gz 74509051
+SHA256 773250ff7bef0086f471d5b5c0a154ba96473f33c5dd61dd70b4a295d0453643 wesnoth-1.1.14.tar.gz 74509051
diff --git a/games-strategy/wesnoth/wesnoth-1.1.14.ebuild b/games-strategy/wesnoth/wesnoth-1.1.14.ebuild
new file mode 100644 (file)
index 0000000..fd823fc
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.14.ebuild,v 1.1 2006/12/16 03:18:08 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+RDEPEND=">=media-libs/libsdl-1.2.7
+       !dedicated? (
+               x11-libs/libX11
+               >=media-libs/freetype-2 )
+       >=media-libs/sdl-mixer-1.2
+       >=media-libs/sdl-image-1.2
+       media-libs/sdl-net
+       nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+       if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+               die "Please emerge sdl-mixer with USE=vorbis"
+       fi
+       if ! built_with_use media-libs/sdl-image png ; then
+               die "Please emerge sdl-image with USE=png"
+       fi
+       games_pkg_setup
+}
+
+src_unpack() {
+       unpack "${A}"
+       if use server ; then
+               sed \
+                       -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+                       -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+                       -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+                       -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+                       > "${T}"/wesnothd \
+                       || die "sed failed"
+       fi
+}
+
+src_compile() {
+       filter-flags -ftracer -fomit-frame-pointer
+       if [[ $(gcc-major-version) -eq 3 ]] ; then
+               filter-flags -fstack-protector
+               append-flags -fno-stack-protector
+       fi
+       egamesconf \
+               --disable-dependency-tracking \
+               --without-fribidi \
+               --with-localedir=/usr/share/locale \
+               --with-icondir=/usr/share/icons \
+               --with-desktopdir=/usr/share/applications \
+               $(use_enable lite) \
+               $(use_enable server) \
+               $(use_enable server campaign-server) \
+               $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+               $(use_enable editor) \
+               $(use_enable tools) \
+               $(use_enable nls) \
+               $(use_enable nls dummy-locales) \
+               $(use_enable !dedicated game) \
+               $(use_with gnome) \
+               $(use_with kde) \
+               || die
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc MANUAL changelog
+       if use server; then
+               keepdir "${GAMES_STATEDIR}/run/wesnothd"
+               doinitd "${T}"/wesnothd || die "doinitd failed"
+       fi
+       prepgamesdirs
+}