dev-python/cppy: C++ header library for writing Python extension modules (new package)
authorVictor Payno <vpayno+gentoo@gmail.com>
Mon, 13 Apr 2020 22:24:44 +0000 (15:24 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sun, 26 Apr 2020 03:11:48 +0000 (20:11 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/cppy/Manifest [new file with mode: 0644]
dev-python/cppy/cppy-1.1.0.ebuild [new file with mode: 0644]
dev-python/cppy/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/cppy/Manifest b/dev-python/cppy/Manifest
new file mode 100644 (file)
index 0000000..6312cdc
--- /dev/null
@@ -0,0 +1 @@
+DIST cppy-1.1.0.tar.gz 11777 BLAKE2B 3bdeba7ee9bb478b51090a52077abc44ee74f72439c3cf2bca898bfc84bd97993bf4dd20d641a1952e2738e3f6b89434f7435fe0a5a8302f91ebef9d02729686 SHA512 9ef4db580c963219a111ab10bc263cdf2c4386e27fce8ffe5c785fc7e8f6c6b60cb23ce918959c6f17194fd6977cc65fa64d167a0b62e6cff0cf662154bc734c
diff --git a/dev-python/cppy/cppy-1.1.0.ebuild b/dev-python/cppy/cppy-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..5ab0e33
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="C++ header library which makes it easier to write Python extension modules"
+HOMEPAGE="https://pypi.org/project/cppy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cppy/metadata.xml b/dev-python/cppy/metadata.xml
new file mode 100644 (file)
index 0000000..16cf244
--- /dev/null
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>vpayno+gentoo@gmail.com</email>
+               <name>Victor Payno</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>gyakovlev@gentoo.org</email>
+               <name>Georgy Yakovlev</name>
+       </maintainer>
+       <longdescription>
+               A small C++ header library which makes it easier to write Python extension modules. The primary feature is a PyObject smart pointer which automatically handles reference counting and provides convenience methods for performing common object operations.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">cppy</remote-id>
+       </upstream>
+</pkgmetadata>