Fix broken autotools handling.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:27:55 +0000 (14:27 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 14:27:55 +0000 (14:27 +0000)
Package-Manager: portage-2.1.2_rc4-r5

app-text/djvu/ChangeLog
app-text/djvu/djvu-3.5.17.ebuild
app-text/gnome-spell/ChangeLog
app-text/gnome-spell/gnome-spell-1.0.7-r1.ebuild

index 6620d4d61e66fe32dccb679ff201b4cc623fbc1e..89edb2abfe910164b27aa0fc96eac1ee5ded9e91 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-text/djvu
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.54 2006/12/08 23:03:12 drizzt Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/ChangeLog,v 1.55 2007/01/04 14:24:46 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> djvu-3.5.17.ebuild:
+  Fix broken autotools handling.
 
   08 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> djvu-3.5.17.ebuild:
   Add ~x86-fbsd keyword
index 522c4f0af5840c25c99b5227e5bc0fe0ed26a148..28d0b81ef770160f3475b3b14f1cac044ee2ce61 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.17.ebuild,v 1.16 2006/12/08 23:03:12 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.17.ebuild,v 1.17 2007/01/04 14:24:46 flameeyes Exp $
 
-inherit nsplugins flag-o-matic fdo-mime eutils multilib toolchain-funcs
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit nsplugins flag-o-matic fdo-mime eutils multilib toolchain-funcs autotools
 
 MY_P="${PN}libre-${PV}"
 
@@ -40,13 +43,11 @@ src_unpack() {
        # Replace autochecking acdesktop.m4 with a gentoo-specific one
        cp "${FILESDIR}/gentoo-acdesktop.m4" "${S}/gui/desktop/acdesktop.m4"
 
-       aclocal -I config -I gui/desktop || die "aclocal failed"
-       autoconf || die "autoconf failed"
-       libtoolize --copy --force
+       AT_M4DIR="config gui/desktop" eautoreconf
 }
 
 src_compile() {
-       # assembler problems and hence non-building with pentium4 
+       # assembler problems and hence non-building with pentium4
        # <obz@gentoo.org>
        replace-flags -march=pentium4 -march=pentium3
 
index 67692a7be3fe3b3c3b57331662d07512209909b8..975708947a8a2b7a4ba4343de596dca5bb57034b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-text/gnome-spell
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/ChangeLog,v 1.78 2006/09/08 19:22:40 tcort Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/ChangeLog,v 1.79 2007/01/04 14:27:55 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  gnome-spell-1.0.7-r1.ebuild:
+  Fix broken autotools handling.
 
   08 Sep 2006; Thomas Cort <tcort@gentoo.org> gnome-spell-1.0.7-r1.ebuild:
   Stable on alpha wrt Bug #133939.
index 8c15a57f6df988f90e24ce7b563d61f0064e30aa..7c7c82ddc5f785e5d6578dcdade05adeeda29e3d 100644 (file)
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/gnome-spell-1.0.7-r1.ebuild,v 1.11 2006/11/12 04:17:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-spell/gnome-spell-1.0.7-r1.ebuild,v 1.12 2007/01/04 14:27:55 flameeyes Exp $
 
-inherit libtool eutils gnome2
+WANT_AUTOMAKE="latest"
+WANT_AUTOCONF="latest"
+
+inherit eutils gnome2 autotools
 
 DESCRIPTION="Gnome spellchecking component"
 HOMEPAGE="http://www.gnome.org/"
@@ -23,8 +26,7 @@ RDEPEND=">=gnome-base/libgnome-1.112.1
 DEPEND="${RDEPEND}
        dev-util/intltool
        dev-util/pkgconfig
-       sys-devel/gettext
-       >=sys-devel/autoconf-2.59"
+       sys-devel/gettext"
 
 DOCS="AUTHORS ChangeLog NEWS README"
 
@@ -51,13 +53,5 @@ src_unpack() {
        epatch ${FILESDIR}/${P}-remove_gnome_h.patch
 
 
-       einfo "Runnig aclocal"
-       aclocal || die "aclocal failed"
-       einfo "Running autoconf"
-       WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
-       einfo "Running automake"
-       WANT_AUTOMAKE=1.9 automake || die "automake failed"
-       einfo "Running libtoolize"
-       libtoolize --copy --force
-
+       eautoreconf
 }