media-libs/mesa: Add lima and panfrost
authorMatt Turner <mattst88@gentoo.org>
Mon, 15 Jul 2019 22:49:17 +0000 (15:49 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 15 Jul 2019 22:52:02 +0000 (15:52 -0700)
panfrost should be usable in mesa-19.2.

Closes: https://bugs.gentoo.org/686218
Closes: https://bugs.gentoo.org/687896
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/mesa-9999.ebuild

index b45409f64da61ed90eaa9abda1c3fee299865ffe..de737e259d618e835caacd4e1bc60b6c66052561 100644 (file)
@@ -30,7 +30,7 @@ RESTRICT="
 "
 
 RADEON_CARDS="r100 r200 r300 r600 radeon radeonsi"
-VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris nouveau vc4 virgl vivante vmware"
+VIDEO_CARDS="${RADEON_CARDS} freedreno i915 i965 intel iris lima nouveau panfrost vc4 virgl vivante vmware"
 for card in ${VIDEO_CARDS}; do
        IUSE_VIDEO_CARDS+=" video_cards_${card}"
 done
@@ -54,7 +54,9 @@ REQUIRED_USE="
        video_cards_i915?   ( || ( classic gallium ) )
        video_cards_i965?   ( classic )
        video_cards_iris?   ( gallium )
+       video_cards_lima?   ( gallium )
        video_cards_nouveau? ( || ( classic gallium ) )
+       video_cards_panfrost? ( gallium )
        video_cards_radeon? ( || ( classic gallium )
                                                  gallium? ( x86? ( llvm ) amd64? ( llvm ) ) )
        video_cards_r100?   ( classic )
@@ -401,11 +403,15 @@ multilib_src_configure() {
                fi
 
                if use video_cards_freedreno ||
+                  use video_cards_lima ||
+                  use video_cards_panfrost ||
                   use video_cards_vc4 ||
                   use video_cards_vivante; then
                        gallium_enable -- kmsro
                fi
 
+               gallium_enable video_cards_lima lima
+               gallium_enable video_cards_panfrost panfrost
                gallium_enable video_cards_vc4 vc4
                gallium_enable video_cards_vivante etnaviv
                gallium_enable video_cards_vmware svga