dev-python/flask-nav: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:37 +0000 (09:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:51:37 +0000 (09:51 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/flask-nav/Manifest
dev-python/flask-nav/flask-nav-0.5.ebuild [deleted file]

index 7abfb4dbcce892c1550d9fd73d8a6827ba2d9c93..9b9e51c62b38b546dfa0298bc988a9a40814c714 100644 (file)
@@ -1,2 +1 @@
-DIST flask-nav-0.5.tar.gz 11579 BLAKE2B e643a7b49214ae164da390ca6c2b6b00fde6fc0848b4ff2c74749034d0e225bd8a5388e64db69a88e8edba91af9635ef843b133ab7bfabb33f92eec562930133 SHA512 94ebd858754c0ac936b43762cf427c381faa40de86e73b487d6b415d099696e6216b96ad9fefa62516cefd8e51e7ef282e01e1a492783ab696a9fd3602de7e78
 DIST flask-nav-0.6.tar.gz 12270 BLAKE2B eff90b6fc08629139012e2d920b4d464ed06954040a5e97636a7aa4d59d11654839460ef52477cfcec967bd774d942028a53675d682e850f08f6359c5cfbb54e SHA512 a7930687425a53fac9ad9a7cb65c2e2a759a0c9660189965bf37ea6e9925dd869074d37a283801631b3e6c3391f9f4167e0a36294104f72970e876b5a7a0930c
diff --git a/dev-python/flask-nav/flask-nav-0.5.ebuild b/dev-python/flask-nav/flask-nav-0.5.ebuild
deleted file mode 100644 (file)
index 4529342..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Easily create navigation for Flask applications."
-HOMEPAGE="https://pythonhosted.org/flask-nav/"
-# docs are missing from PyPI tarballs
-# https://github.com/mbr/flask-nav/pull/12
-SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="
-       dev-python/dominate[${PYTHON_USEDEP}]
-       dev-python/flask[${PYTHON_USEDEP}]
-       dev-python/visitor[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
-       sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}