net-mail/getmail: version bump to 4.53.0
authorTim Harder <radhermit@gentoo.org>
Tue, 17 Jan 2017 20:34:16 +0000 (15:34 -0500)
committerTim Harder <radhermit@gentoo.org>
Tue, 17 Jan 2017 20:34:43 +0000 (15:34 -0500)
net-mail/getmail/Manifest
net-mail/getmail/getmail-4.53.0.ebuild [new file with mode: 0644]

index e44d0e29de72dbd5f61644dd33d3a2ee17a1c138..a6dc4b2c2a4f24155c5959c4e954aa4ec2b4d8a2 100644 (file)
@@ -1 +1,2 @@
 DIST getmail-4.52.0.tar.gz 191578 SHA256 d192098460e54c10af518aabae0b0c13024281b17c4ec2dd6ebe2fde69a6f75f SHA512 85ae1db2c76e83f7f76f8ad2f7d2478e22f271baf56f22dc819916ca0932578d82942b785050ef859b1189afbd2e0bde56e0987c1f59ecf3abdcc5a6b630ceda WHIRLPOOL 67382eead739849db8917e319773348c31da22edfc3637ef220444a7fd4e027e352da9432938802ee8917c71043e020f305bb628d8af2ebad92f4e2b34d28025
+DIST getmail-4.53.0.tar.gz 191688 SHA256 282596fe33b5a24b3aefe5b268f57efbcdd5b980478901418045b481636f92ab SHA512 f67e377129f73b7dd639ccba77695b460b7496442b64be5a464dc5588e94e3bb53d5749743d61fdde8887da45b93468bd12080337d52898fd69e6da47c51bcb6 WHIRLPOOL 776017d774d0a357f92487476ea56f1f19879b80087c00ee0974c58c45f11f3428c19e0158ae03eb9267cafe333636d5e171040a1d4485aefaaff26fd0f5b5d3
diff --git a/net-mail/getmail/getmail-4.53.0.ebuild b/net-mail/getmail/getmail-4.53.0.ebuild
new file mode 100644 (file)
index 0000000..6b4c136
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos ~x64-solaris"
+IUSE="ssl"
+
+python_prepare_all() {
+       sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+               -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+       distutils-r1_python_prepare_all
+}