dev-python/pyroute2: add missing PYTHON_REQ_USE="sqlite"
authorHenning Schild <henning@hennsch.de>
Sun, 16 Jun 2019 14:04:38 +0000 (16:04 +0200)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 16 Jun 2019 18:54:14 +0000 (13:54 -0500)
Closes: https://github.com/gentoo/gentoo/pull/12267

Signed-off-by: Henning Schild <henning@hennsch.de>
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild b/dev-python/pyroute2/pyroute2-0.5.5-r1.ebuild
new file mode 100644 (file)
index 0000000..c144bf2
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library."
+HOMEPAGE="https://github.com/svinota/pyroute2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""