dev-python/pathspec: 0.8.0 + QA
authorSebastian Pipping <sping@gentoo.org>
Tue, 14 Apr 2020 19:53:10 +0000 (21:53 +0200)
committerSebastian Pipping <sping@gentoo.org>
Tue, 14 Apr 2020 20:13:06 +0000 (22:13 +0200)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22

dev-python/pathspec/Manifest
dev-python/pathspec/pathspec-0.8.0.ebuild [new file with mode: 0644]

index e8cfef2900125d9b901df59db4d610e36d8d9044..21b66cc6a9ae8e6331fabb422bfdc1f1f0ffd1b4 100644 (file)
@@ -1 +1,2 @@
 DIST pathspec-0.7.0.tar.gz 24306 BLAKE2B 4256a658de2160d3487281dcb5a488c804320ec5b0bd8e20fdaf51bef8fc90f4e7fb48c404ce43508633c23d866b41e7e13cfa3897929459b244e75401b84ca1 SHA512 3171d39405eb586945261b11781b966e0771649dd7caa8f8a5bbd26223a37931c17bd50a4706d603a637a10460e9b3730c21f0eff7dc92d7e73ae570641a900c
+DIST pathspec-0.8.0.tar.gz 26256 BLAKE2B 3d4f2238c515253d83bfd17a2f3319e38024d4fbb22fb0f078bbcca73d3aff45f246a35752c4039b0d88f204ae49b4467b2d9e3b9134e14a7a171895dac770be SHA512 e0cb1883d11506b3d11963397db98a0fd3411f56df7c3e2ab3ac44116ab53977112bb51d1918591afc48b9c08f9cf997d34beba373aafbfbca2aa8749ffaf6c8
diff --git a/dev-python/pathspec/pathspec-0.8.0.ebuild b/dev-python/pathspec/pathspec-0.8.0.ebuild
new file mode 100644 (file)
index 0000000..088b3fb
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility library for gitignore style pattern matching of file paths."
+HOMEPAGE="https://github.com/cpburnz/python-path-specification https://pypi.org/project/pathspec/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+distutils_enable_tests setup.py