dev-tex/dot2texi: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 22:28:58 +0000 (17:28 -0500)
committerAaron Bauman <bman@gentoo.org>
Sat, 9 Nov 2019 22:28:58 +0000 (17:28 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-tex/dot2texi/dot2texi-3.0.ebuild

index e45b8a9557321fda729b405fe3d8cdddbb00ec16..f18a2c57e6c8c61ec4411e9a2e53767ad1fb8753 100644 (file)
@@ -1,18 +1,19 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit latex-package
 
 DESCRIPTION="Create graphs within LaTeX using the dot2tex tool"
-HOMEPAGE="http://www.ctan.org/tex-archive/help/Catalogue/entries/dot2texi.html"
+HOMEPAGE="https://www.ctan.org/pkg/dot2texi"
 # Taken from http://theory.uwinnipeg.ca/scripts/CTAN/macros/latex/contrib/dot2texi.zip
 SRC_URI="mirror://gentoo/${P}.zip"
 
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
 IUSE="pgf pstricks examples"
 
 DEPEND="app-arch/unzip"
@@ -22,10 +23,10 @@ RDEPEND="pstricks? ( dev-texlive/texlive-pstricks )
        dev-texlive/texlive-latexextra
        >=dev-tex/dot2tex-2.7.0"
 
-S="${WORKDIR}/${PN}"
-
 TEXMF="/usr/share/texmf-site"
 
+S="${WORKDIR}/${PN}"
+
 src_install() {
        latex-package_src_doinstall sty pdf
 
@@ -33,7 +34,7 @@ src_install() {
        dodoc ${PN}.tex
 
        if use examples; then
-               insinto "/usr/share/doc/${PF}/examples"
-               doins examples/*
+               docinto examples
+               dodoc examples/*
        fi
 }