x11-wm/awesome: bump.
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 15 Jan 2016 20:33:22 +0000 (12:33 -0800)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 15 Jan 2016 20:34:26 +0000 (12:34 -0800)
Package-Manager: portage-2.2.24
Acked-by: Alex Alexander <wired@gentoo.org>
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
x11-wm/awesome/Manifest
x11-wm/awesome/awesome-3.5.7.ebuild [new file with mode: 0644]

index a285414e62271309a3bdba46c22f6e84709fbbae..c2fba59f46eaae1f4535fed164ea8fe4bdb5c0bd 100644 (file)
@@ -1,2 +1,3 @@
 DIST awesome-3.4.15.tar.bz2 762323 SHA256 4207f5cbed25d0e7ab35157165d923c2ccf04fded5b3d5fc130134ce9ed5ddfd SHA512 18bb2659e1e7c18a8917f606d635e968daa31a5be4c6d93a109603aace9b5d8b5fd0b8ac1d13ba3d6f2c5c42661204ce80c5ea322088cd358ec5e164b760c339 WHIRLPOOL 74da6197f2e4e5f3d99a11e99c26563f6a145181bab5c017b7ee330041864527551a230ce6dc6109bb5510621fe874921c7caa72c095fa2be6fbdb69e02da1dd
 DIST awesome-3.5.6.tar.xz 720112 SHA256 37f49de187825425cb3096fc870959d5fec9302b22ffd0f2874d8a18e85046d7 SHA512 8d89bf46956276a8bcf106bb255c051e8382b08617e17691134a8f3e5db3ec9f7773581c02ce62d23e72499f7b1e60fe4322c211e41219b5bffd1897a96f6cf6 WHIRLPOOL 8ec944f1113f7b7b7c6857c02a6c657aec05ddf23674c75a7cf571d4a65720ed4f5f1d28b0fdac032c12ea5e9a54f655d080c6af4e1d314b8c00bf2b9e806d01
+DIST awesome-3.5.7.tar.xz 722864 SHA256 ba7f92b0ab8b729c569b19b098b0a08339d8654e3c040d07ad02cf99641ceecf SHA512 0b57efa6ba55e28fee56bec96dbf3c47249b2d70b21e1a7760d4367a0ba42d9936c1c6b78afa4aa3050a60cf34189551ea53b208ec8ec9f6563a905463550515 WHIRLPOOL ea368fa058aa1c6a143e6f24231adeb47c5e0d26c462b076d8930a49f72c94097555a542405360c107a9e724f4fcc0993a0ff8b53102dfb072db2a9b04f52d9a
diff --git a/x11-wm/awesome/awesome-3.5.7.ebuild b/x11-wm/awesome/awesome-3.5.7.ebuild
new file mode 100644 (file)
index 0000000..cfc244f
--- /dev/null
@@ -0,0 +1,140 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+CMAKE_MIN_VERSION="2.8"
+inherit cmake-utils eutils
+
+DESCRIPTION="A dynamic floating and tiling window manager"
+HOMEPAGE="http://awesome.naquadah.org/"
+SRC_URI="http://awesome.naquadah.org/download/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="dbus doc elibc_FreeBSD gnome"
+
+COMMON_DEPEND="
+       >=dev-lang/lua-5.1:0
+       dev-libs/glib:2
+       >=dev-libs/libxdg-basedir-1
+       >=dev-lua/lgi-0.7
+       x11-libs/cairo[xcb]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/libxcb-1.6
+       >=x11-libs/pango-1.19.3[introspection]
+       >=x11-libs/startup-notification-0.10_p20110426
+       >=x11-libs/xcb-util-0.3.8
+       x11-libs/xcb-util-cursor
+       x11-libs/libXcursor
+       >=x11-libs/libX11-1.3.99.901
+       dbus? ( >=sys-apps/dbus-1 )
+       elibc_FreeBSD? ( dev-libs/libexecinfo )"
+
+# graphicsmagick's 'convert -channel' has no Alpha support, bug #352282
+DEPEND="${COMMON_DEPEND}
+       >=app-text/asciidoc-8.4.5
+       app-text/xmlto
+       dev-util/gperf
+       virtual/pkgconfig
+       media-gfx/imagemagick[png]
+       >=x11-proto/xcb-proto-1.5
+       >=x11-proto/xproto-7.0.15
+       doc? (
+               app-doc/doxygen
+               media-gfx/graphviz
+       )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS="AUTHORS BUGS PATCHES README STYLE"
+
+src_prepare() {
+       # bug #408025
+       epatch "${FILESDIR}/${PN}-3.5_rc1-convert-path.patch"
+       epatch "${FILESDIR}/${PN}-xsession.patch"
+
+       # bug #507604
+       epatch "${FILESDIR}/${PN}-3.5.5-util.lua-xdg-icons-fix.patch"
+       # bug #509658
+       epatch "${FILESDIR}/${PN}-3.5.5-cflag-cleanup.patch"
+
+       # bug #571544
+       # Merged upstream
+       #epatch "${FILESDIR}/${PN}-3.5.6-fix-multi-instances-focus.patch"
+
+       epatch_user
+}
+
+src_configure() {
+       mycmakeargs=(
+               -DPREFIX="${EPREFIX}"/usr
+               -DSYSCONFDIR="${EPREFIX}"/etc
+               $(cmake-utils_use_with dbus DBUS)
+               $(cmake-utils_use doc GENERATE_DOC)
+               )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       local myargs="all"
+
+       if use doc ; then
+               myargs="${myargs} doc"
+       fi
+       cmake-utils_src_make ${myargs}
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use doc ; then
+               (
+                       cd "${CMAKE_BUILD_DIR}"/doc
+                       mv html doxygen
+                       dohtml -r doxygen || die
+               )
+       fi
+       rm -rf "${ED}"/usr/share/doc/${PN} || die "Cleanup of dupe docs failed"
+
+       exeinto /etc/X11/Sessions
+       newexe "${FILESDIR}"/${PN}-session ${PN} || die
+
+       # GNOME-based awesome
+       if use gnome ; then
+               # GNOME session
+               insinto /usr/share/gnome-session/sessions
+               newins "${FILESDIR}/${PN}-gnome-3.session" "${PN}-gnome.session" || die
+               # Application launcher
+               domenu "${FILESDIR}/${PN}-gnome.desktop" || die
+               # X Session
+               insinto /usr/share/xsessions/
+               doins "${FILESDIR}/${PN}-gnome-xsession.desktop" || die
+       fi
+}
+
+pkg_postinst() {
+       # bug #447308
+       if use gnome; then
+               elog
+               elog "You have enabled the gnome USE flag."
+               elog "Please note that quitting awesome won't kill your gnome session."
+               elog "To really quit the session, you should bind your quit key"
+               elog "to the following command:"
+               elog "  gnome-session-quit --logout"
+               elog "For more info visit"
+               elog "  https://bugs.gentoo.org/show_bug.cgi?id=447308"
+       fi
+
+       # bug #440724
+       elog
+       elog "If you are having issues with Java application windows being"
+       elog "completely blank, try installing"
+       elog "  x11-misc/wmname"
+       elog "and setting the WM name to LG3D."
+       elog "For more info visit"
+       elog "  https://bugs.gentoo.org/show_bug.cgi?id=440724"
+       elog
+}